bug 64 bits

Discussion in 'French' started by ajt60, May 9, 2017.

  1. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    bonjour
    je joue à RF1 puis RF2 depuis des années, UNIQUEEMENT en OFFLINE.
    mais je n'ai jamais pu lancer RF2 en 64bits en Windows 10, que ce soit avant ou apres Steam.
    mon PC I5 est bien en 64bits, CG Nvidia 980Ti

    j'ai tout désinstallé, tout effacé RF1 et RF2,
    et reinstallé seulement RF2 proprement, mais il me jette toujours.

    > sans la beta DX11, quand je lance depuis le launcher, ( case Forced 32bit décochée ), ou depuis le 64bit.exe,
    il me fait des msg erreurs type "Gmotor2" , ou "Runtime to terminate Visual C++" ...

    > avec la Beta DX11, quand je lance depuis le launcher, ( case Forced 32bit décochée ), il reste au launcher.

    Pourtant, Pcars et Assetto tournent en 64 sans problemes .... ;)

    le probleme est qu'en 32bits sur DX11, je ne peux pas lancer plus de 15 IA ....
    ( quels que soient les mods et circuits, (Isi, URD, ou autres ... )

    Quelqu un saurait il m'aider à identifier la cause ?
    Par avance merci de votre aide ... car apres plusieurs mois en 32bits, JE CRAQUE !!!!
     
  2. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,419
    Likes Received:
    2,440
    I use Win10 and rF2 in 64 bit without any problems. rF1 should not in any way interfere with rF2. Must be something in conflict. Have you tried starting steam with Admin privledges?
     
  3. Juan

    Juan Registered

    Joined:
    Aug 3, 2015
    Messages:
    50
    Likes Received:
    6
    what i do is to start steam without admin privledges, but the rf2 aplicacions in those routes i do that and works fine for me.

    C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Bin32
    C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Bin64
    C:\Program Files (x86)\Steam\steamapps\common\rFactor 2\Launcher
     
  4. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    4,419
    Likes Received:
    2,440
    In steam, right click on the rfactor2 icon on the left side of the screen. Then choose properties and then Verify. This might discover something missing.
     
  5. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    Hi guys

    thanks for elements ... but :
    > I checked integrity, all files OK, last update DX11 downloaded this morning
    > start Steam with or w/o Admin is no effect about 64bit bug
    > start directly the RF2.exe with or w/o Admin is no effect about 64bit bug

    but there is new error message :
    "application didnt started correctly ( I know .. ) 0xc000007b "

    and I discovered this :
    when I click right on the RF2.exe, and select "check compatibility",
    I see here that RF2 program is setup for windows8.
    I can change but only for W7, W8 or Vista. There is not W10 available...
    ( and Im on W10 !!! )

    What does it mean ?
    Should I start under W8 ?
    But I dont have this version, my PC was delivered equiped W10 ...

    Thanks for your help and support ;)
     
  6. Max Dralle

    Max Dralle Registered

    Joined:
    Mar 16, 2017
    Messages:
    238
    Likes Received:
    145
    disable the compatibility flag and try again ... :)
     
  7. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    I tried both : with and w/o flagged the "compatibility mode W8" ...
    No result ....

    I looked that error is linked to 07xc000007b ...

    do you know how fix this ?
     
  8. Max Dralle

    Max Dralle Registered

    Joined:
    Mar 16, 2017
    Messages:
    238
    Likes Received:
    145
    Nope, sorry.

    But a search indicates it might be driver related and / or you c++ installation is either corrupted or missing some components.

    I'm not at home, so I cannot chekc for myself, but isn't there something like a "Support" folder in the "rFactor 2" directory ?
    In there, you could find the needed additioanl software packages like DirectX and C++ (vcredist_x64.exe).
    If you find them, try to reinstall them and run windows update afterwards.

    Also make sure, you're using the most recent drivers for your graphics card and if all that doesn't solve it, you might want to follow this link http://support.microsoft.com/kb/929833 to find out if some of your system files are corrupted.

    Hope that helps ... :)
     
  9. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    I downloaded and run the latests 2015 C++ x64 and x86 .exe.
    I added in RF2 support folder the 2 edistx64 and x86 . exe too.
    but nothing changed.
    I scanned the MS link you indicated. He detected nothing.
    I will check my nvidia 980Ti drivers, but all others games are running well ...
    I will check also DX updating,

    my question is :
    how to check that C++ is correctly installed ( content and locations in disk) and updated
    ( because I have MANY/ALL versions installed from 2005 version on my recent computer ... )

    after, I dont see and still lost ....
     
  10. Max Dralle

    Max Dralle Registered

    Joined:
    Mar 16, 2017
    Messages:
    238
    Likes Received:
    145
    Just copying those C++ .exe files into the support directory won't help at all.
    That directory is rather a supplemental storage for 3rd party stuff that is needed to run the game properly.

    So in a nutshell, you should install the vcredist files that were in there, to make sure, it's not those that are causing the problem.

    Unfortunately, MicroSoft is releasing new C++ version about every year and they are supposed to peacefully co-exist.
    Admittedly, it is hard to keep track of all those version, but every installed one should be automatically updated through "Windows Update".

    Maybe someone from S397 could chime in and give you a hand in solving your isssue ?
     
  11. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    thanks for your interest in my pain ... ;)

    because I would like to race offline with more than "only" 15 IA .... ;)
    I think that this limit is due to the 32b version. Is it correct ?
    So that's why I tried 64b version and discovered the bug detailed here in this post.

    So I really expect to understand what is occuring this 07xc00007b error ...

    Due to my I5, Nvidia 980Ti and full HD TV 42",
    I setup all the ingame video config to the Maximum/Optimal/Performance ...
    all is running well : visuals very nice, fluidity OK, etc ... except this limit to 15 IA !

    But may be : would I put more IA if I reduce this video setup ?

    Diferently formulated :
    Is there a link between the ingame video config and the maximum acceptable IA in 32b version ?
    I plan to test this WE, but may be somebody already knows .... ;)

    Thanks,
     
  12. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,273
    Likes Received:
    1,396
    Only thing you can do is to reduce AI graphic detail to "Low", maybe that will help to get a few more AI's running. But yes, 32-bit is the cause of this problem, 32-bit can only allocate 4 GB of RAM.

    Have you tried removing x64 plugins? Plugins are usually the reason rF2 crashes on start, many plugins are not DX11 compatible.
     
  13. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    thanks Stonec for comments.
    Can you detail :
    > which x64plugins I would remove ? those of DX9, DX11, C++ ?
    > where can I find the corrects ?

    I already checked/updated the "C++ 2015" in x64 and in x86,
    but I have long list of C++ installed from 2005 version ...
    do I need to update manually all others ?

    thanks ....
     
  14. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,257
    Likes Received:
    4,324
    Which plugins do you have? You want to remove/disable any that draw things on the screen.

    For your runtime error, make sure you run ALL of the programs in the Support\Runtimes folder. Run all of them, there are 4.
     
  15. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    Im not to sure to understand what you ( Lazza and Stonec ) really mean about "plugins"
    what are you exactly mean ? plugin of what ?

    So :
    I downloaded from MS and run all updated versions of each Visual C++ versions on computer.
    also I runned all 4 programs of the Support/Runtimes folder
    but ....
    nothing happened, always 07xc000007b error as starting rF2 64b

    HELP !!!!!!!!!!!!!!!!! ;) ;)
     
  16. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    New :
    I have this on my computer : Microsoft ASP.NET MVC 4 Runtime 4.0.40804.0
    Is it correct to run rF2 in 64b ?
    I dont have any Microsoft.NET Framework ... is it normal ?
     
  17. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    9,257
    Likes Received:
    4,324
    @ajt60 The plugins we are talking about are rFactor 2 plugins. Things like DeltaBest, TrackMap, the weather plugin, etc. But judging by that other thread you found (and googling the error code) it seems more likely to be related to the NET framework or directx.
     
  18. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    so no plugin as described installed here, only some mods track and cars, nothing really "exotic" ...
    i see that directx is now automatically updated via W10 update, correct ?
    i will run this too tonight
     
  19. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    so,
    I run last update W10
    I run Malware, CCleaner, Roguekiller to clean everything
    I activated framework in options too
    NOTHING changed.

    other question :
    I have for each Visual C++ ( 2005,2008,2012,2013,2015 etc ... ) , for each type ( x64 & x86 ), 2 versions with different serial numbers.
    is it normal ?

    also I run all solutions proposed below :

    http://steamcommunity.com/app/341940/discussions/0/615086038663012427/

    https://www.bitdefender.fr/support/comment-resoudre-lerreur-l&039;application-n&039;a-pas-reussi-%C3%A0-demarrer-correctement-(0xc000007b)-cliquez-sur-ok-pour-fermer-l&039;application-1105.html

    https://www.microsoft.com/en-us/download/details.aspx?id=22

    NO IMPACT ....

    what do you think too about "DLL-files Fixer". ?

    I DONT UNDERSTAND AT ALL what Im still lost ...
     
  20. ajt60

    ajt60 Registered

    Joined:
    Aug 1, 2016
    Messages:
    48
    Likes Received:
    5
    to try recover all potential missing.dll files in C++ ,
    Do you think I should reinstall W10 ?
    if yes, which method select to do it please ?
    thnaks
     

Share This Page