[REL] BMW Sauber F1 2008

Discussion in 'Vehicles' started by chappielike2009, Sep 29, 2015.

  1. chappielike2009

    chappielike2009 Registered

    Joined:
    Jun 17, 2012
    Messages:
    108
    Likes Received:
    1
    Last edited by a moderator: Oct 3, 2015
  2. Allyc4t

    Allyc4t Registered

    Joined:
    Jan 19, 2012
    Messages:
    10
    Likes Received:
    0
    why do people insist on uploading stuff onto websites which force you to sign in or use your social media account just to download the file you're after?
     
  3. PRC Steve

    PRC Steve Registered

    Joined:
    Sep 27, 2012
    Messages:
    1,302
    Likes Received:
    7
    Thanks Chappie.
     
  4. Frenky

    Frenky Registered

    Joined:
    Jul 10, 2014
    Messages:
    383
    Likes Received:
    156
    Hey chappielike2009 (or someone else) is it possible to host it on Mega.co.nz? The site I'm pointed to, wants to install a strange rar file first.
     
  5. Kendo1978

    Kendo1978 Registered

    Joined:
    Oct 4, 2010
    Messages:
    33
    Likes Received:
    2
    yes, trying to download an exe file when I tried the link. :confused:
     
  6. samcar304

    samcar304 Registered

    Joined:
    May 6, 2013
    Messages:
    197
    Likes Received:
    24
    Car looks great but is Undrivable... it has no 5th 6th or 7th gear in the setup and is very sluggish when accelerating
     
  7. PRC Steve

    PRC Steve Registered

    Joined:
    Sep 27, 2012
    Messages:
    1,302
    Likes Received:
    7
    Yeah it certainly takes a bit of navigating to actually be sure you aren't downloading some sh*t.
     
  8. chappielike2009

    chappielike2009 Registered

    Joined:
    Jun 17, 2012
    Messages:
    108
    Likes Received:
    1
  9. Frenky

    Frenky Registered

    Joined:
    Jul 10, 2014
    Messages:
    383
    Likes Received:
    156
    Thank You Chappielike2009! I really like this car. Great physics and no problems with gears here :D

    However I have some graphical glitches:
    - There is something wrong with the heat haze: from cockpit view, other cars are looking very blurry (only when there is heat haze involved)
    - I cannot load the car in the showroom. When I press ALT-TAB with Windows, I can see at least three different loading errors. I think some graphical components can't be loaded.

    Hopefully it is possible for you to look into this.

    EDIT: After playing and doing some races a lot of AI don't finish, because of engine overheating problems. After digging into the engine file, I discovered the line:
    LifetimeEngineRPM=(21400.2,100.4). The first figure basically means an optimum RPM of 21400, which can never be reached, and the second one is the difference in RPM where engine lifetime is halved. Without going too much into details now, I would kindly suggest to change the line to:
    LifetimeEngineRPM=(17000,500)
    Test it and if AI still overheat their engine, you can slightly increase the second value.
     
    Last edited by a moderator: Sep 30, 2015
  10. samcar304

    samcar304 Registered

    Joined:
    May 6, 2013
    Messages:
    197
    Likes Received:
    24
    Please Ignore my comment i accidentally loaded a track setup from in the car options and it was fine when i used default setup. :)
     
  11. chappielike2009

    chappielike2009 Registered

    Joined:
    Jun 17, 2012
    Messages:
    108
    Likes Received:
    1
    Thanks for pointing that out looks like i missed a few textures out. i have solved the engine also and updated the download link.
     
  12. Frenky

    Frenky Registered

    Joined:
    Jul 10, 2014
    Messages:
    383
    Likes Received:
    156
    Wow, quick reaction! Will test later.
     
  13. Frenky

    Frenky Registered

    Joined:
    Jul 10, 2014
    Messages:
    383
    Likes Received:
    156
    Hey, I solved the over heating problem with changing the line "BoostEffects" in the engine file. The last figure is much too big :p
    But still there is a problem with the AI. They are driving like they are having less power. On most tracks they barely reach 270 kph. Anyone else have this problem and/or a way to solve this? BTW, this is with AIStrenght on 100%.

    Thanks Chappie for the car. The driving itselves is really cool with this car!

    EDIT: found another minor graphical thing: the revs lights are working on Nick Heidfelds car. But on Robert Kubicas car, the lights aren't working
     
    Last edited by a moderator: Oct 3, 2015
  14. jakobdylan

    jakobdylan Registered

    Joined:
    Jun 15, 2012
    Messages:
    188
    Likes Received:
    4
    franky plaese can you share with us the fix for heating problem?
     
  15. chappielike2009

    chappielike2009 Registered

    Joined:
    Jun 17, 2012
    Messages:
    108
    Likes Received:
    1
    Is this still happening in version 2008f ? Do you have mechanical failures on timed scaled?
     
  16. Frenky

    Frenky Registered

    Joined:
    Jul 10, 2014
    Messages:
    383
    Likes Received:
    156
    @ jakobdylan, yes I can share the version I have right now. But I think it is fair to ask chappielike2009 for his permission first.
    @ chappielike2009. Yes, it still happens with v2008f. The AI simply don't reach 7th gear at all. Even with low downforce level. EDIT: it couldn't be that the AI cars are bottoming, right? I really have no clue what is causing this.

    EDIT2: Yes, I do have mech failures on time scaled.

    EDIT3: I use these settings right now in the engine file (solved the heating problems and lower the sluggish feeling of the engine):

    EngineInertia=0.0518 //By lowering this one, the engine feels more twisty!!!!!
    IdleRPMLogic=(3775, 4330)
    IdleThrottle=1.0 // throttle multiplier to help maintain idle speed
    LaunchEfficiency=0.996 // efficiency (0.0-1.0) of launch control, or 0.0 if N/A
    LaunchRPMLogic=(11800.0, 14000.0) // holds RPM in this range before launch (used for AI even if launch control is N/A!)
    LaunchVariables=3
    RevLimitRange=(17500.0, 250.0, 7)
    RevLimitSetting=6
    RevLimitAvailable=1
    //RevLimitSpecial=(gr=-8000,gn=-4000,g1=-200,g2-100,g3=-100,g4=-100,g5=-100,g6=-100,g7=500) // Gear specific offset rev limits can be enabled via special instructions (gr=,gn=,g1=...g9=) which represent reverse, neutral and gears 1 through 9. For example g3=-500 would decrease the maximum RPM in 3rd gear by 500 RPM.
    RevLimitLogic=10
    RevLimitHardTime=0.01
    EngineMapRange=(0, 1, 5)
    EngineMapSetting=2
    EngineBoostRange=(0, 1, 3)
    EngineBoostSetting=0
    BoostEffects=(-500,-0.025,-0.028)
    BoostTorque=-0.025
    BoostPower=-0.000025
    //EngineBoostRange=(0, 1, 2)
    //EngineBoostSetting=1
    //BoostEffects=(125.0, 0.060, 0.50) // RPM increase per setting, fuel increase per setting, engine wear rate per setting
    //BoostTorque=-0.0043 // 0.4% less torque per setting (applies to all RPMs)
    //BoostPower=0.00122 // % more horsepower per setting
    EngineBrakingParams=(2,1900)
    EngineBrakingLimit=(-16,-16,-16,-16,-16,-16,-16,-16,-16,-16,-16)
    EngineBrakingGear0Limit=(-25,-29,-36,-44,-53,-62,-71,-80,-90,-100,-110)
    EngineBrakingMapRange=(0, 0.05, 21)
    EngineBrakingMapSetting=5
    OptimumOilTemp=108.1 // degrees Celsius at which engine operates optimally
    CombustionHeat=55
    EngineSpeedHeat=1.05e-003
    OilMinimumCooling=7.25e-004
    OilWaterHeatTransfer=(1.5e-002,2.50e-004) // heat transfer from oil to water (base, w/ engine speed)
    WaterMinimumCooling=9.75e-004 // heat dissipated without radiator
    RadiatorCooling=(1.15e-03, 1.50e-04) // cooling rate with velocity (base, per setting)
    LifetimeEngineRPM=(16450,550) // (base engine speed for lifetime, range where lifetime is halved)
    LifetimeOilTemp=(114.5,4.50) // (base oil temp for lifetime, range where lifetime is halved)
    LifetimeAvg=16500 // average lifetime in seconds
    LifetimeVar=2290 // lifetime random variance

    BTW, revs lights on Kubicas car are working now :)
     
    Last edited by a moderator: Oct 4, 2015

Share This Page