Blender; just a few pointers needed.

Discussion in 'Modding' started by Navigator, Aug 1, 2015.

  1. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Well, be honest; who didn't see this coming? ;)

    I got Blender working and I can import gmt files.
    From that point on, I spend about 5 hours this night to see what I could do and I'm starting to get a bit frustrated.

    Importing one cone for instance, isn't going to do it; I have to import more. But there are some things I can't work out........I can imagine that if you understand 3dsmax, auto cad and "those kind of programs", you understand buttons and their text a bit, but I don't and this is all new for me.
    I will find out how it works, no problem, give it time. But some things I get stuck on after 5 hours and thought I'd ask.

    Things I'm having problems with are:

    - should you just load the .scn file and the gmt's will be loaded automatically? Because the system hangs than....... Need an overview to place the cones different.
    - loading more gmt's at once did work a bit, but cones are one pixel big........cant see them. I can zoom, but they go out of screen than as it zooms to the middle.
    - importing one cone, gives me a cone description at the right side with 3 triangles behind it; should I care about that for giving the cone another place?
    - when deleting that one cone; I get a few extra in that right column that I have to remove too. Importing a lot of gmt's, will give me a days work to delete from the program; can't be right, I must be missing something here?

    Off course I have 1001 more questions, but I just wanted to ask those I shed tears on.......I really can't seem to find those out. The others; less important and I will try to find out myself.

    So, some pointers would be very nice if you will.
    Thanks in advance!
     
  2. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    This is hard........pffff.........

    To give an example; I got more cones in there (imported a lot of gmt's) and placed one different. Now how do I export (or save)? I tried export, but I got the screen that showed all the gmt's there are, clicking "export" brought me back to the picture and the cone was again in its old place.
    Just imported the one cone than and moved it. Clicked somehow on export.......don't know how I did it again, but the gmt in the folder was "new" so I thought I had it.
    Loaded the gmt in the proper folder and started the game; doesn't load :(

    This is really challenging my patience and I'm starting to think this too is not for me. Its to difficult, even with all the info I read, small movies I see :(
     
  3. Traveller

    Traveller Member

    Joined:
    Oct 7, 2010
    Messages:
    806
    Likes Received:
    347
    First off, go to Windows/ Toggle System Console to open it up. The status messages from the scripts are displayed there. It can take several minutes to load a track SCN. The messages displayed there let you know that the program hasn't hung.

    I always move the mesh itself, rather than the object. When you move your cones, be in Edit mode. You can do this by clicking the white triangle for the object in the Outliner View, or selecting Edit Mode in the lower left corner of the screen. You'll know you're in that mode when you Select All and the the vertices and lines of the mesh are all highlighted.

    To export, be in Object Mode. Select the Object(s) you want to export. The " |" will be highlighted for the object(s) to be exported, and you'll see "Object Mode" in the lower left. See the Export section in the documentation.
    ________________________________________________________________"/\"

    Export messages will be displayed in the System Console.

    Hit the "5" on the numeric keypad to switch to ortho mode-- look to the upper left of the 3D display to see the mode. It is easier to navigate than in perspective mode. At least for me. You can zoom in to various locations via the camera angle. I think there is a command to center on a selected object, but I can't think of it right now.
     
  4. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    There might be something wrong, because when I do the scn; I waited an hour.......and still nothing. The console says the proc is 25% busy.

    Anyway; as 3dsmax, this might be to big for me also......... I'm getting frustrated as can be, just wanting to figure it out and I can't.
    I know its a good explanation, but I don't even get half of it. I don't even know what a mesh is. Some things are made of even 5 things and I have to move them al separate........I can't click the one thing because Blender is going back to object mode; I have to pick one of the 5 triangles and move it one by one.

    As with 3dsmax; Im just not smart enough and its not fair to keep asking, so I won't.

    Thanks for the help Traveller!
     
  5. Traveller

    Traveller Member

    Joined:
    Oct 7, 2010
    Messages:
    806
    Likes Received:
    347
    What is the track that is not loading?

    Also, hit "A" to Select All in edit mode. You'll be able to move the entire mesh that way.

    Watch some Blender tutorials on Youtube. You'll pick up the basics.
     
  6. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    The track is Searspoint.

    I got the cone moved somehow and I can see it is now 10 kb while all the others are 8kb.
    I saw lots of movies, but my very poor knowledge of "this kind of stuff" lets me fail to lay connections between things. If you know this stuff well, you can relate and lay those connections.
    I am one that shouldn't be doing this I painfully start to realize. No modding from me, just a few small alterations here and there.

    Still playing with it as I can't leave it alone, but I just get irritated and mad :(
     
  7. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Could I just have something wrong with installing or a setting?
    I (stayed up all night, can't let it go, pfff.... shouldn't do that ;) ) reïnstalled Blender, copied the files in the right place again and still; if I just import the scn (all is white and grey then, shouldn't the colors be in there too?) it all loads.......and then; if I just export one item, without even doing something to it; the output is larger and the track won't load, the bar gets stuck........

    Do you have any ideas on that?
     
  8. Traveller

    Traveller Member

    Joined:
    Oct 7, 2010
    Messages:
    806
    Likes Received:
    347
    The display is set to "solid" after an import. Or maybe it is set to the existing setting-- which is "solid" when you start Blender. Anyway, I haven't written code to change it as part of the import process. Set it to "texture" or "material" to see the colors.

    Objects exported with these scripts most likely are going to be larger than those provided by the 3DSMax exporter, as my export code writes them out in a brute force manner-- all triangles.

    As for the broken load after export, I can't tell you why without knowing more.
     
  9. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Ah, okay; I thought maybe you could see a connection between those things; the file getting larger and not loading. But there is none as I understand.

    Have to work now, but will look up how to set the display to texture or material when I get back home.

    I would love to give you more info, but I don't know what kind of info?
     
  10. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Finally had some time to make the info more visible as I didn't know how to get proper info across.
    I decided to make some screenshots.
    I can't make them smaller because it isn't readable than, hope its not to big.

    So I start up the program and do nothing else.
    The problem of outputting a get that make the track not want to load (as far as I know its that) is the same when I alter the position of the cone or not, so for this time, I didn't alter it to keep it simple.
    Some times I delete the camera, cube and something else first, but tried without doing that and its still the same (those 3 things are in there when you start up for me).

    I click "rFactor import" and select just the one cone (this time, tried all/scn too). I make sure the setting is for rF2.
    It opens but I can't see the cone, its to small. I can't select the cone and "view selected" because nothing happens; I have to click on one of the 3 triangles and do "view selected" than as shown in the picture:

    [​IMG]

    If I would work on the cone, I would have to select one of the 3 triangles again; "a" doesn't work to select them all and would I click the word "cone" itself (so it gets white) than I can't select "edit mode" as you can see in the picture:

    [​IMG]

    Now thats not relevant because -as I said- without working on it, the problem is there too.
    I just click the word "cone" so it gets white and again to the rFactor menu on the top; there I select to export with directory (tried the other one too and placed it by hand; same thing happens).
    A picture of that:

    [​IMG]

    So, thats all I do; open the program, import and right away export and the track will not load.

    Are there some menus you want to see screenshots of or something else? There are so many settings.......I might have done something wrong.
    I installed over 3 times now and removed the old folder before installing, but the reactor menu on top is always there when I reinstall and before I install the scripts even........it might keep some memory anyway? Maybe a setting I messed up too?

    I hope you can understand my rambling :)
    I also hope you can help me out a bit; I feel so close to it now.........just can't get there ;)

    Thanks in advance!
     
  11. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Edit, I just saw some more!
    I thought with the console, you were talking about the windows console and I saw just now that Blender has its own.......sorry!

    I can see things in there; when I open the program alone it says:
    [​IMG]

    After just importing the cone:
    [​IMG]

    And after exporting the cone:
    [​IMG]

    Is this useful?? (Hope so!) :)
     
  12. Richard E Long

    Richard E Long Registered

    Joined:
    Apr 20, 2011
    Messages:
    17
    Likes Received:
    0
    It is good that you found the Blender Console - as you can see, there is a good bit of info there. It will become even more useful as your project gets bigger.

    From the Console log capture, it looks like Blender & the rFactor I/O scripts are doing what they are designed to do.

    Walking thru your screenshots -
    1)
    When you 'select the cone' I believe what you are doing is selecting the icon Blender uses for an Empty. With Traveller's scripts (aka, rFio), Blender's Empty icon represents a GMT file. Blender's Empty, so rFio's GMT, is represented by the black 3-axis item sitting in the middle of your 3D view. When you select 'one of the 3 triangles', you are actually selecting the mesh, or geometry, of the actual cone. The reason there are 3 triangles is there are 3 separate mesh objects in that one GMT. A common occurrence.

    Look to the right of the Object/Edit mode popup menu (at the bottom of the 3D view). There is another popup menu that sets your 3D view drawing level. In your screenshots, this is set to Solid (the white sphere). To see the texture, you need to select Texture from that menu.

    2)
    When you have the 'cone' selected, you have an Blender Empty (rFio GMT) selected. There is nothing to take into Edit mode. You will need to select one, and only one, of the mesh objects. Then you will be able to go into Edit mode.

    3)
    You have things correct in this screenshot. You do want to select the Empty/GMT to export, which is what you have. From your Console capture, it looks like this step worked as expected.

    It doesn't look like you are doing anything wrong in Blender (other than not being familiar with a new environment - don't worry, it will become easier if you stay with it).


    The issue appears to be something going on in your ModDev setup. You haven't defined how you have your track setup in the ModDev:Locations folder. So a quick layout review:

    ModDev
    ---Locations
    ------TrackName
    ---------Track // contains tdf, scn, etc
    ---------GMTs // contains GMT files
    ---------MAPs // contains image files

    Not a required layout, but typical. The important part is to define the actual paths in the SearchPath= lines at the top of your SCN file. Look at other SCN files to see how folks do that. ModDev needs to know where to look for these parts.

    Next I always have ModDev setup as windowed, as opposed to full screen, because rFactor may display an error dialog during track loading. You won't see those errors in fullscreen, but they will appear on top of a windowed rFactor.

    Also you will want to have your rFactor Launcher setup with ModDev having a 'trace=3' (no quotes). There's a line in the Launcher's ModDev section for entering that parameter. Once you have that set, the most verbose trace file will be written (over-written) on each launch of ModDev. The file will be located at:
    Users/-you-/Documents/rFactor2/ModDev/UserData/Log/trace.txt
    Review the trace file for possible clues as to what is happening.

    Hang in there...
     
  13. Richard E Long

    Richard E Long Registered

    Joined:
    Apr 20, 2011
    Messages:
    17
    Likes Received:
    0
    ..oh..
    your screenshots show you are in perspective mode. you will want to be in ortho mode. the 5 key on the numeric pad will switch between the two mode.
     
  14. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Thanks for your time and looking into it Richard!

    I made the .scn so that it runs in game like this:
    //-------------------------------------------------------

    SearchPath=.
    SearchPath=SEARSPOINT_IN
    SearchPath=SEARSPOINT_IN\SEARSPOINT_IN
    SearchPath=SEARSPOINT_IN\Assets\GMT
    SearchPath=SEARSPOINT_IN\Assets\MAPs


    //-------------------------------------------------------

    If that was not okay; the game (devmode) should run this track anyway right?
    The folders are setup: Searspoint_in and Assets, two folders and two lose files; a .tdf and a .dds
    In "assets" there are two other folders; GMT and MAPS, the first one has all the gmt's in there and the other has all the .dds files in there.

    Now Blender does put the gmt back where it came from; I checked.


    I didn't find the "ortho"' mode in there, did find the button though and selected "rendered" and it gave me the picture indeed.

    I did the trace thing and there is a lot of information in there :)
    However, when the loading gets stuck and I have to ctrl/alt/del, there is not much information anymore.
    I started up the game and from that point on, what was in the trace file, I skip for now, this is what came axtra after clicking "race":

    specialfx.cp 3765: Entered SpecialFX::Setup()
    steward.cpp 8551: Entered Steward::Setup()
    dynman.cpp 731: Entered DynMan::Setup()
    sound.cpp 1328: Entered Sound::Setup()
    render.cpp 1679: Entered Render::Setup()
    onscreen.cpp 3568: Entered OnScreen::Setup()
    plrfile.cpp 2965: Entered PlayerFile::Setup()
    plrfile.cpp 2084: Attempting to save to C:\Users\Wim2\Documents\rFactor2\ModDev\UserData\player\player.TMP
    plrfile.cpp 2108: Retcode: 0 for renaming to C:\Users\Wim2\Documents\rFactor2\ModDev\UserData\player\player.JSON
    game.cpp 1017: Setting RFM "AllCarsTracks.rfm"
    game.cpp 1896: Entered Game::Init()
    game.cpp 1900: got past replayman init
    vidman.cpp 2137: Entered VidMan::Init()


    First of; I go and try another track and gmt now; see if the same thing happens as you said something might be wrong with the track setup. I will post here what happened.

    Thanks again mate!
     
  15. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    YESS!! YEEEEAHAAAAA!! Sorry, little party in here! :)

    I took the Goldcoast track, loaded a cone, exported and the game ran.
    Then I moved the cone to the middle of the road (so I would see it ;) and exported; DONE!! To get rid of some frustration, I ran it over 6 times ;) But; it happened; I moved something on a track! HA, I'm happy!

    But why now?
    The setup in the scn and folders is the same.
    The only thing different is this cone, had only one triangle instead of three.
    So I looked for a gmt that had 3 triangles, but the only ones having that, were not made out of 3 pieces.........
    I took a pitwall that had 3 triangles and could move the whole thing with one of the triangles; clicking the other two, gave me no arrow to move other things as far as I could see.

    Now at Searspoint, the cone with 3 triangles, is a cone made of 3 pieces too; the foot, the base and the top cover, but all under one gmt.

    Maybe I can use this cone of one piece at Searspoint.
    I can see in Blender what .dds files it uses and I can rename the cone; "newcone1" and so on. Remove the "cone1" from the .scn and fill in there "newcone1". Or just overwrite or something; there are more ways that lead to Rome in this case I think.
    Tinkering with it now! :)
     
  16. woochoo

    woochoo Registered

    Joined:
    Nov 3, 2010
    Messages:
    1,307
    Likes Received:
    2,844
    :D enjoy!
     
  17. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Thank you! :)

    Anyway, I got the cone in there, loading it while I had loaded the .scn from Searspoint and opening just the get from Gold Coast.
    There was a lot to do about naming, files put back on the wrong spot and so on.
    I managed twice, but it was a fuzz!

    I first tried just putting in the gmt and and the dds; didn't work when I loaded it in Blender to put the cone in the right place; it just wasn't there.
    Now, when I duplicated it, I couldn't see the new cone name in Blender and exporting didn't work properly. It also gave the name "newcone" just like I did before, but had already taken out of the scn.
    Blender probably did that itself.

    But now; is there an easier/proper way to duplicate these things?
    I don't know how I managed eventually; a big mess, lots of searching and so on; I might mess something up!
    How to do this normally?
     
  18. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Maybe not the way, but I now got 6 new cones in there. One I got, the rest I deleted and just copied the gmt in its folder, gave the scn some more lines too.
    The names were different in Blender; I named the 5 copies 201,202 and so on, but since I copied cone21, it said in Blender: "cone21.001" and so on.
    No problem, its there now :)

    This was a productive day if I may say so; fiddling with Blender and reading the pdf from Traveller, I tried and convert rF1 material to rF2.
    I did that with a demo version of 3dsimed once but havent got that anymore.
    Just took some car I found in rF1; the ZR Kodi.
    Got to say though; selecting all doesn't work when you try to set them to rF2 in the objects properties.
    Had to do it by hand and that worked for all except one; some dashboard gmt. Did it again, kept saying it was the wrong version.
    I just did // with the corresponding line in the .gen; just had to see if I could get it done ;)
    Slapped some tgm tires under there, borrowed from the rF trainer, did the sound attenuation thing and it ran properly!

    Of course the car looks like crap; there is no shine on there for instance, but that should be doable too in Blender. I fiddle with it some more after a small holiday.

    So, thanks for all the information guys and Traveller for making this all possible in Blender and making the pdf!
     
  19. Traveller

    Traveller Member

    Joined:
    Oct 7, 2010
    Messages:
    806
    Likes Received:
    347
    You're welcome.

    A few things...

    The numerical suffix supplied by Blender is ignored on export. So "X","X.001" and "X.002" will end up being "X" in the end in rFactor. If you copy objects, rename them to "X01", "X02", etc.

    Likewise, be aware of the GMT file name field in the Object's property panel in Blender. That is the name of a given GMT's file.

    I finally understand what you mean when you say triangle in Blender. The...orange upside down "Y" in the Blender Outliner is the parent object container for the mesh objects of a GMT. Editing that can only be done in Object mode. The orange triangles are the mesh objects for the GMT. The white triangle is the mesh data for the mesh object. That is accessed in Edit mode. Below that you'd have a orange sphere, which represents the material data, again in Edit mode; and the checkerboard for the texture data, again in Edit mode.

    The easiest way to duplicate whole GMT's is to copy/paste the file and rename the pasted file(s). All copies will overlay each other in Blender on import, but you'll be able to pick them out in the Outliner. You'd rename them in the Outliner. You can Duplicate data within Blender, but hold off on that, for now.

    The scripts are still a work in progress, and some GMT's may cause issues. Let me know if one is failing to do something. You can check the Blender Console for error messages, or if the scripts crash.
     
  20. Navigator

    Navigator Registered

    Joined:
    Jan 15, 2012
    Messages:
    2,163
    Likes Received:
    332
    Nice, I did the copy thing pretty proper than; who would have thought that?!

    Thanks for the extra info; can't wait to get home and play some more, especially with this now info.

    How awesome you made this; without it Blender would be useless I understand and now you can do everything, even making rF1 gmt's suitable for rF2.
    Thanks again mate!
     

Share This Page