Billboard Tree Transparency

Discussion in 'Track Modding' started by Slwomir, Aug 30, 2019.

  1. Slwomir

    Slwomir Registered

    Joined:
    May 21, 2018
    Messages:
    12
    Likes Received:
    1
    I have finally managed to create working billboard trees thanks to gMaterial tool but I have a strange issue. When I clone and then attach everything to one object, the trees at the front become transparent but only if there is another tree behind. So when I rotate around, the tree at the front become transparent when another tree appears behind. Do you know what might be wrong?
     
  2. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,260
    Likes Received:
    1,202
    Sounds like your using alpha transparency, so you get alpha sorting issues. You have the offset number in the material setting, or you could use chroma blending, which is also better for performance.
     
  3. Slwomir

    Slwomir Registered

    Joined:
    May 21, 2018
    Messages:
    12
    Likes Received:
    1
    Thank you, chroma blending works perfect :).
    I have another question, is there any possibility to see the texture on both sides for non billboard plane?
     
  4. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,260
    Likes Received:
    1,202
    Yes, you can select two-sided in the material settings.
     
  5. Slwomir

    Slwomir Registered

    Joined:
    May 21, 2018
    Messages:
    12
    Likes Received:
    1
    I've ticked two sided but it is still transparent from the other side:

    upload_2019-9-3_7-57-50.png
     
  6. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    913
    Likes Received:
    430
    I would suppose that it is deactivated for billboard objects, where the polys always face to the viewer anyway, so it is useless in that case.
    Try another shader.
     
    Last edited: Sep 3, 2019
  7. Slwomir

    Slwomir Registered

    Joined:
    May 21, 2018
    Messages:
    12
    Likes Received:
    1
    Thanks, I changed to different shader ind it worked but I prefer billboards anyway.

    I have another strange issue, my plants seems to be very dark but when I come closer they suddenly get some light/color. The same happens when I turn my view towards the sun, do you know what might be wrong?

    As per below example, the bush at the first plan is the same as on the far plan and the brightness changes depends how close I am to the object.

    I have done my albedos maps I think correctly so I don't know what might be wrong.

    EDIT: Problem fixed, I changed the shader to Bump Spec Map T1 Stamp Vertex and it is working fine :)

    upload_2019-9-9_23-15-40.png
     
    Last edited: Sep 11, 2019

Share This Page