[SOLVED] Beta UI stops Gsync from working

Discussion in 'Bug Reports' started by benkay, Feb 3, 2020.

  1. benkay

    benkay Registered

    Joined:
    Dec 19, 2018
    Messages:
    12
    Likes Received:
    9
    If I run the beta UI, then I cannot get Gsync to activate (running Nvidia surround triples, gsync turned on for fullscreen and windowed apps).

    Rf2 is running in borderless mode.

    Swapping back to the old UI revives gsync, and swapping between the two UIs means gsync works, or doesn't work, repeatedly.

    Are other people experiencing the same?
     
  2. halfwit

    halfwit Registered

    Joined:
    Apr 26, 2018
    Messages:
    13
    Likes Received:
    14
    Not been using the beta but version 1117.I had a lack of g sync on several occasions even when it was showing in the control panel.
    Reinstalling the N Videa drivers seemed to do the trick.
     
  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,249
    Likes Received:
    1,829
    How does one know Gsync has stopped? I have the AMD version, Freesync, and unless I look at a windows driver, I don't notice it's operation. I'm not questioning this is happening, just want to know if Freesync suffers from the same issue. Thanks.
     
  4. halfwit

    halfwit Registered

    Joined:
    Apr 26, 2018
    Messages:
    13
    Likes Received:
    14
    In nvidea control panel on the top left under display is g sync indicator.I tick this and it will show g sync in the game, that's how I normally know it's working.Sorry do not know if AMD has the same indicator in it's control panel.
     
    davehenrie likes this.
  5. benkay

    benkay Registered

    Joined:
    Dec 19, 2018
    Messages:
    12
    Likes Received:
    9
    As halfwit says, you can turn on the gsync indicator in control panel....or, as I do, my monitor built-in OSD has a refresh rate overlay...I turn that on so I have a constant read out of monitor refresh rate in the top right corner of my right-hand monitor.

    If that read-out is varying, then I know g-sync is working, if it's static at max refresh rate (165hz) then I know it's not working.

    I've tried a full driver wipe and re-install with no effect.
     
    Last edited: Feb 4, 2020
  6. Richard Busch

    Richard Busch Member

    Joined:
    Oct 12, 2010
    Messages:
    186
    Likes Received:
    68
    How do I tell if g-sync is working/on? I don't get a message (G-sync is on), but I do get a plug symbol show up when I start a race, practice session.
     
  7. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    7,930
    Likes Received:
    3,424
    The two posts above yours describe how. The plug icon in the game just means you have a plugin running in rF2, not related.
     
  8. Richard Busch

    Richard Busch Member

    Joined:
    Oct 12, 2010
    Messages:
    186
    Likes Received:
    68
    Thanks Lazza. I thought I had done all of the above, but I missed a check mark. All is good now.
     
  9. benkay

    benkay Registered

    Joined:
    Dec 19, 2018
    Messages:
    12
    Likes Received:
    9
    So I figured it out (at least in my case).

    My new motherboard dame with ASUS AiSuite III software. This places a little widget on the desktop to click on to control fan speed profiles etc.

    this seems to be preventing gsync from identifying RF2 running in windowed or borderless mode.

    exiting the AISuite software fixes it for me.

    Every other game I play in windowed/borderless seems to cope with AISuite running so not sure what it is about RF2 specifically, but at least I know how to fix it now.
     

Share This Page