Bare minimum to get track into rf2?

Discussion in 'Track Modding' started by Skynet, Oct 17, 2012.

  1. Mario Morais

    Mario Morais Member

    Joined:
    Oct 26, 2010
    Messages:
    1,451
    Likes Received:
    144
    the problem is Xobjs if you open the track in 3dsimed you don't see it

    don0t need "Response=VEHICLE,TERRAIN " for every object
     
  2. SPASKIS

    SPASKIS Well-Known Member

    Joined:
    Sep 7, 2011
    Messages:
    1,660
    Likes Received:
    16
    Thanks a lot Mario. I already solved the problem of loading the track. I have now other problems and I just posted a new thread for it. The way to convert with 3dsimed and import with rf2 is clear now: I will make a specific tutorial for BTB+3dsimed users. Now I have to get the track working.
     
  3. mianiak

    mianiak Well-Known Member

    Joined:
    Oct 5, 2010
    Messages:
    694
    Likes Received:
    42
    Don't forget to mention to optimise the materials, btb exports with a huge amount of duplicated materials,they should all be condensed into one. The main thing about rf2, if you can keep your materials down as low as possible, you can put more detail into your 3d models.
     
  4. SPASKIS

    SPASKIS Well-Known Member

    Joined:
    Sep 7, 2011
    Messages:
    1,660
    Likes Received:
    16
    Thanks for your comments mianiak!

    I had realized of what you mention but I have never changed it so far. I guess I can do it with 3dsimed since gmts are codified and I do not figure out other way to do it. For right now, I need to make the track work before optimizing it. When I get to this point I will try to change things in 3dsimed before exporting the gmt and scn entities. Since in the other post I opened (http://isiforums.net/f/showthread.php/8268-RF2-dev-mode-help) people's replies are related to materials we can follow this conversation in that thread. This thread is about making a track work in dev mode and I already achieved that :)
     
  5. mianiak

    mianiak Well-Known Member

    Joined:
    Oct 5, 2010
    Messages:
    694
    Likes Received:
    42
    You use the material editor in simed and merge materials. Best to first go through them and make a list of what is a duplicate. Let me know if you can figure this out, if not I will make a quick video to show you.
     
  6. Jason Kinchington

    Jason Kinchington Well-Known Member

    Joined:
    Jul 16, 2012
    Messages:
    53
    Likes Received:
    0
    Hi all

    I'm having a problem trying to get a track into game
    I think I got all the plugins I need and I've tried mario scrips
    But I'm getting when I try to load rfactor error saying "can't load gmt jay1 into memory" ( jay1 is my track name)

    I think I'm getting lost somewhere not sure where lol
    Cheers
     
  7. Johannes Kunkel

    Johannes Kunkel Member

    Joined:
    Nov 24, 2010
    Messages:
    16
    Likes Received:
    0
    Hi,

    I´ve been trying to follow this guide, however i get stuck pretty early, I cannot extract the files from within the CoreShaders.mas file. When I try to open it with the rF2 Mas tool I get the Warning "Unknown MAS key."

    Anyone knows what i do wrong?
     
  8. Fabio Pittol

    Fabio Pittol Well-Known Member

    Joined:
    Oct 4, 2010
    Messages:
    236
    Likes Received:
    7
    Yes, you are trying to extract the files from CoreShaders.mas. It still locked.

    Just put it (as a .MAS) in your 3ds Max's HardwareShaders folder. Mine is C:\Program Files (x86)\Autodesk\3ds Max 2012\hardwareshaders.
     
  9. SPASKIS

    SPASKIS Well-Known Member

    Joined:
    Sep 7, 2011
    Messages:
    1,660
    Likes Received:
    16
    OK, framerate is not a problem in my track right now so I will leave it for the end. When I get to that point I will tell you if I need some help. 3dsimed looks quite easy to use and you already provided the key word: "merge". I guess it is caused by different objects using the same material but since in the xpack they are defined as independent material BTB leaves it as it is. As I said I need to work on BTB xpacks to configure them in such a way that they do not produce the typical errors like not having the correct properties from the beginning (use alpha, collide, driveable, surface type,...) or not referenced to a single material when possible. The xpack will get lighter and more powerful. Thanks!
     
  10. Jason Kinchington

    Jason Kinchington Well-Known Member

    Joined:
    Jul 16, 2012
    Messages:
    53
    Likes Received:
    0
    Hi all

    I'm still having problem getting a track to work in dev mode
    So I'm gonna start from the top once again lol (how many times have u lot said that)

    I think I'm getting lost on exporting from max 10 into the game
    Once I've got to the gmt converter 1.52 (or whatever it's called) what do u click on to get the track to work,as in the second post on here.
    I'm not at my PC at moment so not too sure of button names

    Do u click the do all button near the top(it's got 3 tick boxes about it
    Do u put the gmt in assets/gmt folder then click that button
    Or do u click on "do scene" right at the bottom
    Or do u click all 3 of them

    Sorry if it does sound noobish but not done anything like this for rfactor

    The track is crashing as soon as I click race in dev mode if that any help

    My poor head is in such a spin after trying these other scripts and things

    Cheers
     
  11. Skynet

    Skynet Well-Known Member

    Joined:
    Jul 30, 2012
    Messages:
    126
    Likes Received:
    2
    Hi Jason,

    The correct plugins for rfactor2 are V2.25 which you can find in your RF2 install files. Im not sure but isn't v1.52 for rf1?

    Here is a video tutorial by freew67 on how to setup both rf1 and rf2 plugins. Unless you want to install both rf1 and rf2 plugins ignore the batch file he mentions. it is used to switch between rf1 and rf2 plugins.

    http://www.youtube.com/watch?v=_klLNai_ZNE&list=UUpLNIe6w_VLEZ77_b-fb_mg&index=3&feature=plcp

    If the problem is not with the plugins, i fear you may have made a mistake with applying materials and textures to your track like i did. here is another tutorial by freew67 on how to apply textures..

    http://www.youtube.com/watch?v=AjrHlfZa_M4&list=UUpLNIe6w_VLEZ77_b-fb_mg&index=14&feature=plcp

    Also make sure you are using the correct code in your scene file which points to the location of your gmt files.
     
    Last edited by a moderator: Oct 26, 2012
  12. ethone

    ethone Well-Known Member

    Joined:
    Nov 30, 2011
    Messages:
    1,153
    Likes Received:
    37
    The current version of the plugins is 2.52k. I presume Jason just didn't quite remember the 2 before the . or mistyped.
     
  13. Jason Kinchington

    Jason Kinchington Well-Known Member

    Joined:
    Jul 16, 2012
    Messages:
    53
    Likes Received:
    0
    Hi all

    Yeah I do have version 2.25
    And good news is I've got it working in dev mode now
    Not to sure what I done to get it to work I'm pretty sure it was to do with textures and the scn file.

    So now the easy part done lol
    Thanks
     
  14. boblug

    boblug Well-Known Member

    Joined:
    Jan 15, 2012
    Messages:
    51
    Likes Received:
    1
    Black screen on entry

    Ok, so I have been happily building my track and thought maybe I should check to see if it actually works before too much work is done.
    So i took the advice from the beginning of this thread (great advice and macros etc) and of course my track crashed RF2.
    So I stepped back and just tried a simple plane and it loads into RF2 at the garage but when I go to race it is just a completely black screen with the editor details.
    Simple plane with one gmt multi sub texture that exports fine. Scn details from the export and followed as I say all advice from second post.
    I have not included a skybox so will try that but any other ideas or advice from those that have been successful so far. Any special tricks in exporting the gmt etc?
     
  15. iDTDoug

    iDTDoug Well-Known Member

    Joined:
    Oct 5, 2010
    Messages:
    223
    Likes Received:
    6
    can someone post the icon file formats needed. I know some need 8.8.8 and I cant find the thread that has it.
     
  16. mianiak

    mianiak Well-Known Member

    Joined:
    Oct 5, 2010
    Messages:
    694
    Likes Received:
    42
    With this tool you can open existing dds files and it will give you the information of the format it uses.
    http://www.nvidia.com/object/windows_texture_viewer.html
     
  17. iDTDoug

    iDTDoug Well-Known Member

    Joined:
    Oct 5, 2010
    Messages:
    223
    Likes Received:
    6
    I tried opening joesvilleIcon.dds and it crashed that program,
    edit: but dragging it to it kinda worked. just got a giant pink square though.
     
  18. mianiak

    mianiak Well-Known Member

    Joined:
    Oct 5, 2010
    Messages:
    694
    Likes Received:
    42
    Press A to toggle between ARGB and RGB. The pink square is showing the alpha layer.
     
  19. Mario Morais

    Mario Morais Member

    Joined:
    Oct 26, 2010
    Messages:
    1,451
    Likes Received:
    144
    add new version of rf2track script.

    Is only a info to add the dot to the Search Paths.

    (to add the dot, add some path then double-click to change to '.'

    Download v4
     
    Last edited by a moderator: Nov 21, 2013
  20. Galaga

    Galaga Banned

    Joined:
    Jul 16, 2013
    Messages:
    1,292
    Likes Received:
    0
    Edit - Oops. Hang on as I see information here I missed the first time around before I had Max. Let me go through this thread first and then I will report back....

    Edit #2 - OK I am indeed stuck. I read thru the thread and checked something driveable at 0,0,0. My xsectors, etc have materials, etc. Please read on :(

    I am attempting to load a track in dev mode and it is hanging at about 10%.

    In max, I have seven objects. The center line from kml imported via Mario's ImportGeo, track_1, xfinish, xsector1, xsector2, xpitin, xpitout (the last six created via Mario's TrackMaker script). I have assigned the same road_wet sub-material to all of these objects and double-checked correct realroad mapping channels, textures, etc. I have received success messages on export of GMT and scene files.

    On the devmode directory side, I have followed and double-checked instructions at beginning of this thread (reproduced below with confirmation that I double-checked each item).

    My goal is to get the bare minimum into rF2 so I can test track geometry and also to have a baseline for process of elimination of future export/import problems.

    So I am stuck :( and would appreciate any ideas you guys have :)

    In case is helpful, here is my ModDev folder/files --> https://www.mediafire.com/?x1x02q1temjm7r2 and here is my .max file --> https://www.mediafire.com/?e0ygy8xje8k4obj

    (done) Duplicate the Joesville folder inside ModDev/Locations and rename it the way you want (avoid white spaces, use underscore instead).

    (done) Rename Joesville_Speedway.tdf as desired and do the same on the folder with the same name.

    (done) Open the folder mentioned above and delete all files but the .GDB and .SCN ones. Rename them the same way you did on previous item.

    (done) Open the .GDB file (I suggest you to use Notepad++). Change the first line of the code with the name you used on the file. Adjust the other values as you want and don't forget to change the name of the TerrainDataFile accordingly.

    (done) Open the .SCN file. Modify the SearchPath following the name you gave to the folders before.
    Duplicate the line SearchPath={YOURTRACK}\ASSETS\MAPS and rename the copy as SearchPath={YOURTRACK}\ASSETS\JOESVILLE_MAPS. This will avoid some texture mismatches for now.

    (done) Remove the lines starting with //MASFile. Leave only the one that says MASFile=COMMONMAPS.MAS

    (done) Still in the .SCN file, remove all the lights inside the Lighting group. Also, delete all the instances but the XSectors (from Instance=lpole01 until the end of the file).

    (done) Go to Assets/GMT folder. Delete all the GMTs but the xSectors.

    (done) Duplicate the Assets/Maps folder and rename it to Joesville_Maps. And delete all the files of the folder that remained called Maps.

    (done) Delete JoesvilleIcon.dds (optional)

    (done) On 3ds Max, export your mesh inside your track's Assets/GMT folder. (I usually exports to another folder,
    outside rF2 installation, and keep copying and pasting the files I want).

    (done) Insert the corrent instance on your track's .SCN file. To do this and yet keep things organized, I set up gMotor plugin to create a quick scene elsewhere, open it and copy only the instance I want to paste on the track's file.

    (done) By doing that you'll be able to get you mesh working on the rF2 ModDev. If you have any problems, just ask.
     
    Last edited by a moderator: Mar 6, 2014

Share This Page