WIP Audio Issues - GT3 cars

Discussion in 'Bug Reports' started by RaceNut, Feb 9, 2023.

  1. RaceNut

    RaceNut Registered

    Joined:
    May 21, 2013
    Messages:
    664
    Likes Received:
    541
    rF2 version: RC - GT3 update

    Issue 1
    : Following cars exhibit what sounds like engine stumble, interior engine sounds repeatedly fading in and out at moderate to high rpms. May only occur in certain gears in some cases.
    Affected cars (GT3): Bently GT3 / BMW M4 GT3 / Calloway Corvette GT3 / Merc AMG GT3.
    Steps taken to correct: Reduce number of sounds to 64 (from 96). Verify rF2 file integrity (Steam).
    Result: no improvement.

    Issue 2: Engine sample looping (interior) at moderate to high RPMs.
    Affected car: Calloway Corvette GT3
     
    Last edited: Feb 9, 2023
    Devin likes this.
  2. yashiman

    yashiman Registered

    Joined:
    Jan 16, 2012
    Messages:
    231
    Likes Received:
    799
  3. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    7,482
    Likes Received:
    4,395
    #2 Callaway. I didn't hear the engine itself fade out, but there was some part of the engine sound that was looping, the main engine noise was reproduced as expected, just some V8ish background sound that did vary high/low in volume while the tone remained stable.
     
  4. RaceNut

    RaceNut Registered

    Joined:
    May 21, 2013
    Messages:
    664
    Likes Received:
    541
  5. RaceNut

    RaceNut Registered

    Joined:
    May 21, 2013
    Messages:
    664
    Likes Received:
    541
    Could be the same thing I'm hearing, it's not very clear.
     
  6. Lildave

    Lildave Registered

    Joined:
    Jun 19, 2015
    Messages:
    12
    Likes Received:
    3
    I'm having the same issues?
    Aston as well.
     
    Last edited: Feb 10, 2023
  7. Devin

    Devin Member Staff Member

    Joined:
    Dec 30, 2011
    Messages:
    235
    Likes Received:
    189
    Thanks, it's being looked at. If you can find any way to trigger it more reliably, please let me know ASAP
     
    yashiman and RaceNut like this.
  8. RaceNut

    RaceNut Registered

    Joined:
    May 21, 2013
    Messages:
    664
    Likes Received:
    541
    It seems to be pretty random. One lap or two, things are normal. Next lap it may appear, then gone again.
    I did try changing views (as suggested by Yashiman). It did seem to work initially but, next session the issue returned.
    I'll keep trying to uncover possible triggers.

    Thanks for responding, Devin.
     
  9. Lildave

    Lildave Registered

    Joined:
    Jun 19, 2015
    Messages:
    12
    Likes Received:
    3
    I'm doing the same mate, running out of things to try. It's definitely not all cars.
     
  10. RaceNut

    RaceNut Registered

    Joined:
    May 21, 2013
    Messages:
    664
    Likes Received:
    541
    In most cases, the issue seems to occur with V8 engine sounds. The BMW M4 is the outlier from my experience. Testing some cars in other classes may reveal if it's related to a broader sound-engine issue vs isolated GT3 content / update release issue.
     
  11. Spyro

    Spyro Registered

    Joined:
    Jun 18, 2017
    Messages:
    27
    Likes Received:
    11
    I can confirm the sound bug also occur on the V8 Stockcar2018.
    It doesn't seem to be track dependant, and the affected player can change from one session to one another.
    We haven't found yet a way to trigger it, it seems to choose randomly some players when they join a session.
     
  12. Devin

    Devin Member Staff Member

    Joined:
    Dec 30, 2011
    Messages:
    235
    Likes Received:
    189
    Did anyone find this problem with a rear- or mid-engined car yet? All reports point at front-engined cars for some reason
     
  13. Devin

    Devin Member Staff Member

    Joined:
    Dec 30, 2011
    Messages:
    235
    Likes Received:
    189
    A fix has been found and will enter testing today
     
  14. instinkt

    instinkt Registered

    Joined:
    Nov 21, 2020
    Messages:
    99
    Likes Received:
    66
    for me it happens randomly
    I'm really not sure if the issue was present in other cars than front-engined since I driven Aston most of time
    during first tests at Spa I had this then next day it was fine and then on Nords I had this again
    also right after patch I had some sound glitch that significantly muted engine sounds in GT3 and also GTE (the only cars I tested then) but after game restart it went back to normal so whatever I guess
    it isn't as much fucked up like Aston and BMW GTE cars where engine sound is just offset and it's driveable but sometimes it works smooth and sometimes it just doesn't
     
    Last edited: Feb 14, 2023

Share This Page