[SOLVED] Annoying problem, Rfactor 2 wont start

Discussion in 'General Discussion' started by David Turnbull, Feb 20, 2019.

  1. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    Hi guys,

    I have a seriously annoying problem where Rf2 wont start in either VR or monitor. The wierd thing is that when I reinstall the game it will work fine for the first time then after that it wont open, the launcher will come up, I click on my server and the Rf2 logo will come up then disappear, a thumbnail just sits there on taskbar until I go into task manager (where it says not responding) and close it.

    Something similar is happening with VR, I reinstall the headset, reinstall SteamVR and mixed reality app, start them up then open the game and it will run one time completely fine, exit and try again and in the headset it just says VR content loading, while this is happening the desktop screen is black and if I click my mouse anywhere it brings up a Rfactor 2 is not responding box.

    I've tried reinstall of all the Rf2 software, VR software, SteamVR software, cleaned out folder and registry after uninstall so they are fresh when going back in. I've constantly checked for windows updates of which there are none, I've tried opening SteamVR and Rf2 in diffrent ways and nothing makes a diffrence. I've also tried a new DP cable for the monitor and all my USB3 ports on the pc.

    This has been happening for a while now and one minute I think its solved and the next it resurfaces, this is also a fresh install of Win10 and I've just upgraded the pc and its been happening with the old and now new. If it was VR or monitor alone then I'd know where to start but it wont start on any now.

    any ideas because I'm all out of them and its getting so bad I'm considering giving up, Rfactor 2 is the only racing game I've played since its release and now its got me so frustrated.
     
  2. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    788
    Likes Received:
    485
    Not saying I can help with this as I've not had the problem but if you put your system info in here along with the version number from your rF2 install (available in the launcher) it may assist with diagnostic and someone may be able to help. The more info we have the easier it is to come up with an answer (mostly):)
     
    David Turnbull likes this.
  3. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    System info is in my signature, windows build number 1809, rf2 version 1112.
     
  4. JimmyT

    JimmyT Registered

    Joined:
    Jan 16, 2012
    Messages:
    788
    Likes Received:
    485
    Ha, had to turn signatures on.:oops:
    Can't see anything amiss with compatibility. :(
     
  5. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    yeah its wierd, i had problems when i first got the lenovo explorer in that randomly the game would not launch, and then for no reason it would suddenly fire up and run fine, this seemed to be solved with the windows update to 1809, it worked fine for a week or two, then back to not working, now it wont even run on the monitor, something is causing the problem either in windows or some programs ive got installed or content in rfactor2, i dunno what though.

    ive tried updating windows and theres no updates, tried closing all non essential programs and tried unsubscribing to everything in workshop and the problem remains, im so frustrated with it because when it does work its great and runs flawlessly, but getting it to run is some random nightmare that i cant go through each time i want to practise and obviously league races are luck of the draw wether i can even get the game to launch.
     
  6. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,106
    Likes Received:
    1,761
    I've found if I get clicky with the mouse while rF2 is loading sometimes it will hang. Then I'll see the 'not responding' message. SOMETIMES if I wait it will come back. But more often if I wait it will eventually drop back to steam. So make sure you are not multi-tasking while it's loading. And if it does appear to hang, give it a-bit more time.
    good luck
     
    David Turnbull likes this.
  7. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    838
    I would try a system recovery to the time when it worked
     
    David Turnbull likes this.
  8. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    @davehenrie I've literally left it for upto 5 mins and it will just sit there until I clock the mouse then the not responding box will appear

    @Louis This is the second system this is happening on, my last system with 4790k it done it too, ive upgraded since and have a new nvme drive so its all fresh and everything else works flawlessly.
     
  9. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,106
    Likes Received:
    1,761
    That is obviously too long. I have always wondered why certain sections of the program (not including driving on the track) seem to take so long to initiate. For example: I want to see the car in the hangar...."ok..... says the program.....I'll go fetch.......that car........for ..... you....."
    We don't have 386 based machines that have to swap memory every 40 keystrokes.
    Best answer then David is to say, sometimes rF2 just won't load. I can't say why. I just noticed it more often when I wouldn't leave my dang mouse alone.
     
  10. Magus

    Magus Registered

    Joined:
    Jun 27, 2012
    Messages:
    743
    Likes Received:
    452
    Do you have some kind of security software installed that may be blocking rf2 or deleting a file without your knowledge as a false positive?
    Try an integrity check to see if any files have been deleted without your knowledge but if your firewall is blocking rf2 then you may want to have a look to see what is being blocked.
     
  11. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    no security software except win10s own built in defender and firewall, the program is allowed through the firewall and when i verify game files in steam it always comes back fine so no missing files.
     
  12. Goanna

    Goanna Registered

    Joined:
    Jan 19, 2012
    Messages:
    825
    Likes Received:
    570
    I had a similar problem recently, mine turned out to be a wifi dongle that was plugged into a powered USB hub. Plug the dongle directly to computer, no probs, but as soon as I put it in the powered hub, black screen like you have described...dunno if you helps you or not, thought I’d mention it in case you have the same.
     
    David Turnbull likes this.
  13. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    its funny you say that because when this problem first started i thought i had solved it by removing my bluetooth dongle, when i disconnected it the game started everytime for the rest of that night so ive left the dongle out since and only use it if i need to, ill check the rest of my usb devices see if any of them are causing this. thanks
     
  14. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    ok so theres a bit of breakthrough on this....

    Rf2 is working on my monitor again, loading the launcher is instantaneous, when i click my server (any server or sp) the launcher disappears and the splash screen comes up, this will then disappear in 3-5 seconds, then Rf2 will sit as a blank thumbnail on my taskbar for 7 mins 20 secs then suddenly the game will start up and be great from there.

    so theres an initial start up problem thats taking far too long, I've just tried unsubscribe from all non essential content and its still the same, although I only had official content in the first place.
     
  15. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    more info...

    Just tried another reinstall of the game, only official content installed, same thing happening. although its random on how long it will take to open, the quickest ive timed so far is 5 mins 8 seconds, the longest is 7 mins 20 secs, once it starts it runs fine and loads the track rapid. so now it is opening 100% of the time but very slowly.

    EDIT: And now VR is working 100% of the time, but again very slow loading, so far I've ruled out all USB devices as it does the same with only mouse and keyboard plugged in, I've ruled out game files problems with various reinstalls of the game, Graphics drivers have been updated and their good, Windows is fully updated. So just this very slow loading is the problem wherever thats coming from.
     
    Last edited: Feb 21, 2019
  16. Louis

    Louis Registered

    Joined:
    Dec 27, 2016
    Messages:
    1,379
    Likes Received:
    838
    Sorry, for some reason i didnt read the 4th paragraph of your first post
     
  17. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    I think I may have solved this, not 100% sure yet but what I think is happening is....

    When I got my VR headset I noticed that when I would quit from the game my windows power plan would always be changed to high performance (I always set balance so the cpu clocks down at idle) so what I did was lock the PC at balanced power plan using gpedit and finding the power plan options and specifying only balance power plan, this means nothing can change it and it worked in that after using VR the power plan always stayed on balanced. Now I've removed that lock on the power plan Rf2 is starting up quickly again, anybody got any ideas why this is? If it works it works and I'm obviously glad it is but now I'm back to the problem of VR changing my power plan to high performance all the time.
     
  18. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    This is solved.

    It has been caused by the windows power plan setting

    thanks for the help folks :)

    (NO FIX)
     
    Last edited: Mar 22, 2019
    Alex72 and Goanna like this.
  19. David Turnbull

    David Turnbull Registered

    Joined:
    Jan 1, 2013
    Messages:
    120
    Likes Received:
    19
    Update on this problem.....

    Seems it wasnt the windows power plan settings and was more of a random problem I was experiencing due to when I would connect my Logitech G29. There is a compatability problem between my keyboard (Corsair K55) and Steam and any controllers used...

    If Steam was open then I would connect my wheel the game would take ages to start up, but if I closed Steam then connected my wheel then reopened Steam all would be good and the game starts up instantly. So this is an easy fix if you start things in that order.

    There is no outright fix for this and it only seems to affect the Corsair K55 keyboard, Corsair say they know about the problem and are working on a fix but this was upwards of 6 months ago and still no fix but obviously is completely fine using the workaround.

    So if anyone else has this keyboard and is suffering the same problems the workaround is...

    Close Steam
    Connect wheel
    Reopen Steam
    Job done.

    Just thought I'd post this up in case anyone else is pulling their hair out for months like I was :)
     
  20. Glen Field

    Glen Field Registered

    Joined:
    Apr 20, 2017
    Messages:
    9
    Likes Received:
    1
    I have this keyboard and also know that it impacts how my controller works in AC. Causing it to go into an 'unresponsive' mode on and off.
    Oddly though it doesn't impact RF23 as much, but I always have the wheel connected and on before even starting Steam which seems to help for this game. However, for AC I have to use an alternate keyboard ... :( shame as I have the full Corsair set as in keyboard mouse and mat
     
    David Turnbull likes this.

Share This Page