aiw build 156 issues

Discussion in 'Track Modding' started by WheelNut, Mar 22, 2013.

  1. WheelNut

    WheelNut Banned

    Joined:
    May 6, 2012
    Messages:
    123
    Likes Received:
    2
    aiw editor build 156 issue
    i'm having issues getting the ai to follow the paths i create
    i do it in this order and have never had this issue with earlier builds
    main
    pit
    branch main/pit
    corridors
    fast left right
    the ai go to leave the garages then just stop
    if i press i in the garage and let the ai take control of my car it drives straight out the garage and goes around the track following the paths i just created i will go over the track as it was the first i did
    any help would be much appreciated
    is this an issue with this build
    moddev mode crashes a lot now to
     
    Last edited by a moderator: Mar 23, 2013
  2. iDTDoug

    iDTDoug Registered

    Joined:
    Oct 5, 2010
    Messages:
    334
    Likes Received:
    209
    i made my AIW
    path
    pit path (connected)
    grids/pit spots
    now im trying to add a garage path but every option i choose in the menu crashes rf2 to desktop. the aiw file is ok, it reloads but i cant save a new path. i may start over.
     
  3. iDTDoug

    iDTDoug Registered

    Joined:
    Oct 5, 2010
    Messages:
    334
    Likes Received:
    209
    deleted all waypoints
    made new main
    made new pit, connected it
    went to add garage path, CRASH. (using add as 2nd pit).
     
  4. WheelNut

    WheelNut Banned

    Joined:
    May 6, 2012
    Messages:
    123
    Likes Received:
    2
    i have got the ai working but they won't pull into there pitboxes
    if i look at the other tracks there's special waypoints at every pitbox mine doesn't have them
    how do i add these special waypoints or are they meant to be there after i set the pit locations
    any ideas
    thx
     
  5. iDTDoug

    iDTDoug Registered

    Joined:
    Oct 5, 2010
    Messages:
    334
    Likes Received:
    209
    setting pit locations should allow the cars to pit as long as you have a pit lane path nearby that is connected off the main path.
     
  6. WheelNut

    WheelNut Banned

    Joined:
    May 6, 2012
    Messages:
    123
    Likes Received:
    2
    yer it has pit main fast left right
    i have set all pit positions garage positions the ai exit and enter the pits fine but they don't pull into the pit box
    they do like a drive through penalty then run out of fuel just after
     
  7. iDTDoug

    iDTDoug Registered

    Joined:
    Oct 5, 2010
    Messages:
    334
    Likes Received:
    209
    in unsupported options menu, calculate the fuel usage.
    Make sure your xpitin trigger is working.
     
  8. WheelNut

    WheelNut Banned

    Joined:
    May 6, 2012
    Messages:
    123
    Likes Received:
    2
    i got it to work things just need t be done in a certain order i guess
    i did the paths before the pits so i redid the pit path and it worked
    thx m8
     
  9. WheelNut

    WheelNut Banned

    Joined:
    May 6, 2012
    Messages:
    123
    Likes Received:
    2
    well i sort of got it to work but the cars smash into one another when pitting
    has anyone encounted this its wp from pit to pit boxes are connected weird
    [​IMG]
     
  10. iDTDoug

    iDTDoug Registered

    Joined:
    Oct 5, 2010
    Messages:
    334
    Likes Received:
    209
    also check your garagedepth number in the gdb file, the larger the number, the more room they take to enter/exit.
     
  11. WheelNut

    WheelNut Banned

    Joined:
    May 6, 2012
    Messages:
    123
    Likes Received:
    2
    garage depth is 1.9
    if i delete all wp and do the main around the middle and then the pit thats how it connects every time
     
  12. WheelNut

    WheelNut Banned

    Joined:
    May 6, 2012
    Messages:
    123
    Likes Received:
    2
    i made the garage depth 7 so they take a straighter line out the garage and turn into the middle of pitlane and redid the pit path
    and it connected exactly the same way
     
  13. WheelNut

    WheelNut Banned

    Joined:
    May 6, 2012
    Messages:
    123
    Likes Received:
    2
    i am convinced the aiw editor is broken you have to exit the game completely between each step especially when doing main and pit paths
    if you don't the path line goes shooting out the side of the track at one of the ends of the pit path
    if i redo the main it connects the pit path wp to pitbox specials all messed up
    but if i only redo the pit path it all gets connected fine to pitboxes special wp
    this is on other tracks not just the ones im doing
     
  14. iDTDoug

    iDTDoug Registered

    Joined:
    Oct 5, 2010
    Messages:
    334
    Likes Received:
    209
    something isnt right. I deleted my aiw file for vegas and wanted to start from scratch. No file. rf crashed:
    ai_db.cpp 3213: Entered AIDatabase::Init()
    ai_db.cpp 11077: No AIW path found...attempting to create one from max ASE export file
    ai_db.cpp 11100: No max ASE export file found. we have entered a bad state
     

Share This Page