AI pitting early in wet races + other rain issues

Discussion in 'General Discussion' started by RoboCAT10, Dec 8, 2016.

Thread Status:
Not open for further replies.
  1. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,482
    Likes Received:
    1,984
    Marcels responded that it will be investigated. They have been pretty clear about where they are going via the Roadmap updates. I don't recall wet weather tires being discussed in any of these roadmaps. I can therefore assume that, while they are investigating, they are not prepared to release anything either now or the near future. Asking the same question over and over is not likely to move this problem further up the ladder. So look at post #28 from this thread again. Read it over and over. Understand he does not indicate this can or will be fixed quickly. Understand your request was responded to several months ago. And since then, there have not been any announcements that would indicate they are near a solution. You have not been ignored, you have not been discounted, but you have been given an answer.
    When the next update is announced, most likely the UI enhancements, they will often include any other items that are nearing release, but if they do NOT mention wet weather tires, then whatever the next update is, you should be prepared for the same response. IT is not ready now. That is the best I can tell you. And we need to get 2012 out of our heads. ISI has walked away from rF2, S397 was not here 5 years ago, they have begun a process of modernizing rF2. While this may be a bug from the beginning, it is not something S397 has been working on for 5 years. As we have seen these past two weeks, they can move much faster than ISI but that does not mean they can achieve all our desires at the same time.
     
    Last edited: May 10, 2017
    MarcG likes this.
  2. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,282
    Likes Received:
    1,208
    yeah do what I do - consider wet weather broken and don't use it. Like I do with most sims with wet weather.

    shame as some people bang on about rf2 racing day and night and rain features. Shame some of it doesn't actually work. Lol

    and this Imo is why rf2 is playing catch-up as just some parts are FUBAR
     
    RoboCAT10 likes this.
  3. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    569
    Likes Received:
    97
    The pit stop bug only begun happening recently, it was fine before whatever ISI or s397 updated. I'm not sure and I can't understand where abouts the bug even came from. This bug isn't an issue that has been from the start, it's recent.

    Rfactor 2 is a brilliant game, but it could be even better if whoever the current developer was would at least try to fix the current issues rather then moving on to something else and potentially creating a branch of more. Look, I'm not try to bash rfactor, I just feel, and I can't understand why as a developer you wouldn't want to try fix the current issues that have been reported for so long. I come on to this forum everyday in a hope there might be some news, but lately it is all dx11, and while I do think it's brilliant s397 are progressing the game, I think it's sad that current issues don't seem to be getting much attention, even if it wasn't s397 problem to begin with.

    I understand I got an answer, I'm not a complete moron thankyou, I just though that a couple months later, as a rfactor fan I would ask if there has been any progress on this. I don't care if the rain looks average, I just want this bug to be seen to. I can't force anyone to do that, but I can at least ask and take a genuine interest in it.

    I don't know when this bug will be fixed and it seems s397 don't know either, fair play. Will it be fixed at the next update, a year from now, five years? Who knows? No one seems to. Making these posts unlikely makes s397 move any faster, I completely get that, but I at least want to try let them know that this bug does effect some rfactor 2 customers. So until whenever this does get fixed I will continue to follow with interest.

    pit
     
  4. stonec

    stonec Member

    Joined:
    Jun 19, 2012
    Messages:
    3,240
    Likes Received:
    1,366
    It's all about priorities. Currently there are many many bugs that need fixing, like those huge lags in online, which are destroying league races. ISI spent the last 2 years only fixing bugs basically, and rF2 got nowhere. Now we have a new developer that actually has a clear plan, and that is to develop UI/VR/DX11 first. I think this is good as rF2 is finally getting somewhere instead of the last 2 years when it started losing players. It's not that fixing this one bug would take them many days, but once the focus is on bugs, there are at least a hundred similar bugs to this that other people think is important to fix. For a team that is 3 or 4 developers, it's taking the focus away from modernizing the sim, which is their priority at the moment. As much as I like them to solve bugs, I prefer that the core sim gets modernized first. Currently most people are complaining about poor performance in DX11, so optimizing DX11 has to be their first priority.
     
    LokiD and TonyRickard like this.
  5. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    I perfectly understand frustration when a recently introduced bug that should be quite easy to solve and that gets to be a showstopper for racing offline in the rain is unaddressed.

    A similar case occurs for both online and offline if you try to pit in the formation lap. You get teleported back to the grid. For two races already it has prevented me from changing from wet to slicks after the rain stopped prior to the race.

    Like the OP presented bug, it was introduced when the changes for stock cars regarding AI and racing rules that were introduced in B1108.

    We were told about the advantages of steam with respect to hotfixes. These would be cases to demonstrate it.

    For the ones talking about priorities. Was the AI behaviour/rules changing a higher priority than DX11/VR? Apparently it was very urgent. Otherwise we wouldnt be suffering its side effects (bugs).
     
    RoboCAT10 likes this.
  6. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,482
    Likes Received:
    1,984
    Online, you often find Nascar users in locked events (league) with more drivers than most of the other circuits combined. I'm assuming they wanted to begin pushing in that direction and the quick release of updated Nascar Cup cars tends to support that. As to the 1108 update being more of a priority than the dx11/vr, I can't say. I would venture they felt they needed the large group of users to debug the Nascar rules. Just as with dx11, they didn't have a large enough beta pool to discover the many many systems like mine (AMD) that caused problems with the initial release of dx11.
    The advantages of Steam and hotfixes should be hugely apparent with the half dozen or so updates they have pushed out in the last 10 days. But having Steam to distribute something does not mean they have the cure available to send out.
     
    Last edited: May 10, 2017
  7. LokiD

    LokiD Registered

    Joined:
    May 3, 2017
    Messages:
    1,282
    Likes Received:
    1,208
    this isn't an old issue though, its existed through out most gmotor games with rain. Race 07 etcetc
     
  8. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    569
    Likes Received:
    97
    Yes that is correct - it is only a recent issue. It came about apparently in a stock car update. So while that might be good for stock car players, it's ruined the enjoyment of others who were happy with how it was before. That to me shouldn't be right, and we shouldn't just brush it off as "later" or "it's a low priority" or "whenever". Clearly dx11 is their main focus now, but this bug is recent and should be fixed so those players (like myself) enjoyment of the game shouldn't be detracted just because the stock car was updated, and I don't use stock car content at all.

    I am not asking for a fancy new update. I am simply requesting a hot fix to an issue that was otherwise fine before the stock car update. Also I am bemused by some of these comments, that I should just shut up and wait and be patient. How more patient do I need to be? This bug was not here right from the start, it is recent, and it should have been hot fixed sometime ago, or at least attempted to be fixed with even a hint of communication.
     
    ECAR_Tracks, Jon and TonyRickard like this.
  9. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    3,482
    Likes Received:
    1,984
    A) You want a solution when there may not be one right now.
    B) You have already identified the cause and can use steam to correct this for yourself.
    C) Click on rF2, choose properties, then the Beta Tab, then choose beta v1098. If the problem was introduced with v1108, then rolling back to 1098 should correct the problem.
    D)
     
    SPASKIS likes this.
  10. SPASKIS

    SPASKIS Registered

    Joined:
    Sep 7, 2011
    Messages:
    3,155
    Likes Received:
    1,420
    Tip C is actually very interesting and useful for OP since he is racing offline.

    However, tip A is absurd IMO. Studio 397 has the same option as you point out in C. They could bring back to the code of older AI and racing rules.

    Stock car rules and AI should be in a new beta program when DX11 is ready and leave the rest of the users with normal rules. I really think that number of people using stock cars vs regular cars is ridiculous.
     
    ECAR_Tracks and RoboCAT10 like this.
  11. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    569
    Likes Received:
    97
    This still has not been fixed. I created this thread in December last year...
     
  12. MarcG

    MarcG Member

    Joined:
    Oct 4, 2010
    Messages:
    6,616
    Likes Received:
    1,908
    For the thousandth time it's about priorities, Studio397 are clearly still working on porting the game to DX11 and that takes precedent over any other minor issue.

    Edit: you got response on page 2 in case you missed it :)
     
    Last edited: Jul 15, 2017
    jayarrbee36 likes this.
  13. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    569
    Likes Received:
    97
    A minor issue that wasn't an issue a year ago...
     
  14. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    569
    Likes Received:
    97
    Is there any chance somebody could please test this out for me if they get the chance?

    Could you test the FISIR2012 cars in a full wet race and see the frequency of them pitting? Just so I know it's not an issue I have caused myself? This whole thing is driving me insane because I don't have any cement clarification yet.
     
  15. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    569
    Likes Received:
    97
    Is anyone able to please test this for me? To confirm it's not an issue on my end?
     
  16. The Iron Wolf

    The Iron Wolf Member

    Joined:
    Feb 20, 2016
    Messages:
    977
    Likes Received:
    941
    I can confirm I am seeing this with some content, but not with all of it. Interestingly, stock content (Karts at Atlanta) is affected, but not URD EGT and some other mods I play with RaceRfactor tracks. I think it might help if you could record replay of an issue with stock track/stock content and upload here for S397 (or, better in bug reports section). I did same for karts issue. Yes, it's a bug, hopefully one day will get looked at (on top of my list too :))
     
  17. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    569
    Likes Received:
    97
    Thank you, is this happening with the Formula ISI cars for you?

    And yes I might upload a video.
     
  18. The Iron Wolf

    The Iron Wolf Member

    Joined:
    Feb 20, 2016
    Messages:
    977
    Likes Received:
    941
    I haven't tried FISI, but problem is present with stock Karts on at least one stock Track. I think that's enough to have bug looked at. I suspect it might be a bit more helpful if you capture in-game replay instead of video, as it allows to restart from various places and will make it easier to reproduce problem once S397 has time to look into this.
     
  19. Jon

    Jon Registered

    Joined:
    Jun 23, 2017
    Messages:
    137
    Likes Received:
    127
    I noticed at Monaco '66 when driving the Brabham that when there was an accident it would show up Full Course Yellow, even though at that time I don't believe they even had a safety car and even so I had deactivated the stock car rules plugin. However, even after large multiple crashes the warning doesn't appear at Spa '66 in the same car. So, I would suspect that at Spa' 66 the cars don't use the stock car rules and therefore aren't affected by the rain problem. I'll test it at the weekend. There should be a way to completely deactivate stock car rules which should fix the rain problem and also remove the annoying full course yellow at Monaco '66. Perhaps the stock car rules file simply has to be deleted rather than deactivated?
     
  20. The Iron Wolf

    The Iron Wolf Member

    Joined:
    Feb 20, 2016
    Messages:
    977
    Likes Received:
    941
    rF2 has FCY even without Stock Car Rules plugin. IIRC you can disable FCY in session setup (flag rules).
     
    Jon likes this.
Thread Status:
Not open for further replies.

Share This Page