AI constantly pitting?

Discussion in 'Technical Archives' started by tjc, Jun 21, 2012.

  1. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    Had a 6 lap race with the AI at Monza last night after going through practice and qually.

    Really enjoyable experience driving the BT20. Qualified 5th out of 10 cars and made up a couple of places at the start but just as I was getting ready for a bit of a battle all the AI turned off into the pits leaving me tearing around Monza all by myself.

    They did this at least twice in a 6 lap race so needless to say I won quite comfortably (which is not what I was looking for at all)

    I`ve checked around the race settings etc and looked in my player file to see if there`s anything anywhere that`s making them do this but can`t find anything. They did it at Old Monaco the last time I raced there too...

    :confused:

    Anybody got any idea why this is happening and how I can stop it?

    :)
     
  2. raymond2_nl

    raymond2_nl Registered

    Joined:
    Jul 5, 2012
    Messages:
    5
    Likes Received:
    0
    No idea how to stop it, but had a similar experience yesterday.

    Was driving a 15 lap race in Formula Renault 3.5 on Malaysia. AI pitted in lap 12, when my tire wear was showing code yelow (which means between 80 and 50% wear if I'm correct). This also resulted in me winning quite comfortably (I was having quite some very nice, close, battles around 5th place up to that point).
     
  3. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    @ raymond2_nl

    Don`t think it`s the same problem mate as the AI pit on the first lap in the problem I`m experiencing and pit several times during the race which results in no race really. :(

    ---

    Tried racing at historic Monza and Monaco again and still this problem persists which obviously ruins a good race with the AI...

    Anybody got any clues about this or experienced it too?

    I`d really like to find out why this is happening so any help/info would be appreciated.
     
  4. kmw

    kmw Registered

    Joined:
    Jan 3, 2012
    Messages:
    187
    Likes Received:
    1
    How much fuel are you putting in your car? I seem to remember in rF1 that the AI cars used similar fuel load to the Human, but the trouble with this is they are also over cautious and pit around 5 laps early to avoid running out. Therfore, if you set laps of fuel for a 6 lap race, they are likely to pit almost immediatley. Then after a few laps, they may well get the same problem and repeat this. Try putting 13+ laps worth of fuel, and if this cures it, maybe ISI could do something to remedy it this time round.
     
    Last edited by a moderator: Jul 12, 2012
  5. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    Thanks for the reply kmw, appreciate it.

    Iirc I have been using a low amount of fuel but never thought for a second that my fuel level would affect the AI... I don`t remember this in rfactor at all.

    Anyway, it`s certainly worth a try.

    Cheers. :)
     
  6. frankwer

    frankwer Registered

    Joined:
    Oct 5, 2010
    Messages:
    140
    Likes Received:
    1
    I guess the AI cars are equipped with Pirelli tires.
     
  7. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    lol... :D
     
  8. JonathanBenn

    JonathanBenn Registered

    Joined:
    Jul 17, 2011
    Messages:
    14
    Likes Received:
    0
    Yep, I just got this one too. Monza, six laps with weather set to storm. They pitted every lap. I'd understand their cowardice but the weather began to clear up after lap one...
     
  9. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    What amount of fuel did you have in your motor at the time JonathanBenn? Just wondering if it was a low amount and this is causing the problem as kmw has suggested. :)
     
  10. BYF

    BYF Registered

    Joined:
    Jan 14, 2012
    Messages:
    34
    Likes Received:
    0
    If you start a wet race on dry tyres, the AI also seem to start on dry tyres and will all pit at the end of lap 1 to change for wets.

    It does appear the AI run a similar setup to whatever the player car is using, possibly both fuel + tyres.
     
  11. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    Mmm... interesting. Thanks for the input BYF. :)
     
  12. JonathanBenn

    JonathanBenn Registered

    Joined:
    Jul 17, 2011
    Messages:
    14
    Likes Received:
    0
    Just about enough for the race - I think it was about 10 laps. But they just kept pitting every chance they got; I was watching on the tracker down the bottom of the screen.
     
  13. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    Sounds similar to what I`ve been doing as far as fuel amount goes.

    Time to try more laps I think just to see what they do then.
     
  14. tjc

    tjc Registered

    Joined:
    Jun 4, 2012
    Messages:
    5,860
    Likes Received:
    340
    Ok... I tried a 6 lap race last night with the GTR`s at Snetterton with 7 laps of fuel. The AI pitted on the first (possibly second) lap as they have been doing.

    I then had a 6 lap race at Croft with the Meganes but had 10 laps of fuel in and the AI didn`t pit at all...

    So seems like it might be fuel related after all. :)
     

Share This Page