Ai and rain

Discussion in 'General Discussion' started by Jeremy Talbot, Oct 1, 2020.

  1. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,854
    Likes Received:
    2,235
    Eh? I think your getting confused, when the session ends (and it's wet) you simply advance to the next session, not sure why you're waiting at 0:00 for anything. As above you're overthinking it :)
     
  2. Jeremy Talbot

    Jeremy Talbot Registered

    Joined:
    May 5, 2017
    Messages:
    53
    Likes Received:
    39
    Well I advanced to race after waiting for the session to end and they still pitted every lap. They didn't even change tyres or refuel, just drove through pit lane.

    I don't think I'm over thinking it, people have said to never advance session so I took that literally. Plus shouldn't the session end itself and ai not go through a red light at pit exit?

    Anyway it doesn't work either way so it's all good.
     
  3. Kahel

    Kahel Registered

    Joined:
    Jun 6, 2020
    Messages:
    263
    Likes Received:
    188
    Yeah that suck... Billy strange (Youtube) also struggled in a recent video and gave up with rfactor2 (for now)...
    I hope the devs find some time to make the experience a bit more polish for those who like to enjoy offline events...
     
    Jeremy Talbot likes this.
  4. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,854
    Likes Received:
    2,235
    Well if you want to Race you have to Advance to next session, what I said was "Don't ever click "Finish Session"", if you do that before the Time runs out or there's Laps to be completed it messes with the AI. Once the Session has ended normally THEN you can advance to Next Session.
    Regardless have you done what I advised re the player.json? This is the important bit and if it does help please send me the json file which you had issues with.

    FYI I did a race yesterday; Qualifying ended Wet, I started the Race Wet and when it began to dry the dry line appeared and the AI pitted for slicks. All worked just fine (GT3 @ Silverstone GP) and they only came into the Pits that once. :)
     
  5. Jeremy Talbot

    Jeremy Talbot Registered

    Joined:
    May 5, 2017
    Messages:
    53
    Likes Received:
    39
    Yeah Marc I did the player.json thing with the same result. If you want to look at it you're more than welcome :)
     

    Attached Files:

    MarcG likes this.
  6. MarcG

    MarcG Registered

    Joined:
    Oct 4, 2010
    Messages:
    6,854
    Likes Received:
    2,235
    Ok thanks will do later
     
    Jeremy Talbot likes this.
  7. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    639
    Likes Received:
    114
    Hey mate I have had issues with the wet weather AI pitting every lap before. I found that when the lights go out, I restart the race and go from there. I found that when I do that there is no pitting every lap bug. Give that a try and let me know how you go - that workaround has worked for me for a year or so now. However the track must start dry.
     
  8. RoboCAT10

    RoboCAT10 Registered

    Joined:
    Oct 18, 2014
    Messages:
    639
    Likes Received:
    114
    I’d like to try that to see if works so I can have a wet start. However I use the ‘warm up’ session to decide the starting grid (adding in AI in the order I want them to start), so if I was to advance I think it ruins the grid I had. Do you know of another work around? Cheers
     

Share This Page