After the hardware upgrade, the track crashes every time after loading.

Discussion in 'Bug Reports' started by ddooewq, Jun 19, 2022.

Tags:
  1. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    Hello..
    Before the hardware upgrade, I was able to open the game smoothly!
    after hardware update,I'm able to get to the game menu without a hitch, but after loading the track it crashes to the desktop.
    I've done everything I can. Reinstalled the system, cleaned drivers, reinstalled, installed all runtime files, reinstalled steam and the game, and the game still crashes.
    Maybe it's my hardware problem? ?but My cpu, memory, graphics card are not overclocked!
    original hardware information:I7-8700\6800XT\16G DDR4 2666
    new hardware information:I7-12700K\6800XT\32G DDR5 5200
    system:win11
    please help me!
    please help me!
    please help me!
    It's driving me mad.ahhhhhh!!!!!!!!:mad::mad::mad::mad::mad:
     

    Attached Files:

  2. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    6,325
    Likes Received:
    3,644
    First things first. Test it with one S397 car & a default track. I have nearly the same system, (6700XT grumble, grumble) and everything I've tried has worked. If that works, choose the same track with one of the cars you have tried to load.(just ONE)
    Now, what track? What mod? What version of rF2? The last lines of the trace file mentions a missing suspension piece. I think you may have a corrupted car.(note: that was THINK not KNOW) Are you using a custom pace car?(if so, fall back to S397's pace car) It also mentions a missing Le Mans mas file. Try another S397 track Finally, at what % does the program crash? if it's below roughly 85%, then that says track failure. If it's 86 to 100%, that would be a car file not loading correctly.
     
  3. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    Thank you for your reply.
    All crashes appear when loading to 100%. There is no sign, it just crashes directly to the desktop. Neither the S397's track and car nor third parties are immune.
    In fact, sometimes the game can be played normally, but the probability is very small. The last available track, reloading after changing the car crashes, and vice versa. There is a high probability of a crash when changing the track or changing the vehicle. Sometimes it can enter the track, but it only runs for a few minutes and then crashes to the desktop.
    In the latest track files, the first ones I choose are Le Mans and BMW GT3, both of which are S397 files. In fact, now that I've tried changing tracks and cars (Silverstone and Corvette C8GTE), I've managed to get on the track and I can drive on the track as well. However, I exited to the menu and selected the BMW GT3, entered the track again, and crashed again at 100% loaded. Again I opted to go to the track with the Corvette C8GTE, huh, got in, but after less than 100 meters it was not running and a new problem arose. I can hear the sound, but the screen is stuck, the mouse cannot be operated, and I can still step on the throttle pedal! wow~
    My game version is the latest version
    thanks again for the reply
     

    Attached Files:

  4. Herve_Versabeau

    Herve_Versabeau Registered

    Joined:
    May 27, 2015
    Messages:
    34
    Likes Received:
    12
    Rename userdata in userdata.old and restart game
     
  5. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    6,325
    Likes Received:
    3,644
    When you re-installed, did you completely delete all the folders withing the rFactor 2 folder? Using steam to un-install, then re-install does not remove all the folders and files. So a complete wipe is only achieved by having Steam un-install, THEN using windows file explorer to delete the rFactor2 folder and any sub-folders inside rFactor2.
    But before you do that, your original post lists some of the things you tried. Did you re-name the UserData folder and then restart rF2 via Steam? That should cause rF2 to rebuild a fresh copy of the UserData folder. If that cures things, you can open the renamed folder and copy your controller profiles to the new UserData/Controller folder.
     
  6. Highlandwalker

    Highlandwalker Registered

    Joined:
    Nov 11, 2016
    Messages:
    671
    Likes Received:
    1,941
    How many sticks of memory have you installed, there has been problems reported when using 4-sticks of DDR5. If you have 4-sticks installed, try removing 2-sticks to see if that helps. Have you got adequate cooling for your cpu, 12gen cpus tend to run rather hot.
     
    Last edited: Jun 19, 2022
  7. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    Thanks for your reply, yes, I deleted all files including UserDate folder. After reinstalling the game, I can drive around the track, but it crashes after a few minutes. .
     
  8. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    Thank you for your reply. 2 sticks of 16g. I have XMP turned on, there may be overclocking reasons, I am going to turn off xmp and try it out.
     
  9. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    I reinstalled the game and deleted all files. Now open the game again and drive successfully. But still there will be problems. The only time I successfully entered the track was a lot of error messages in the tracking file.

    XMP has been turned off
     

    Attached Files:

  10. DJCruicky

    DJCruicky Registered

    Joined:
    Jan 25, 2012
    Messages:
    1,422
    Likes Received:
    761
    I have not got a solution for you sorry.
    - Does Windows Event Viewer give any clue what might be wrong?
    - Have you tested out other games just to rule out rFactor2?
    - Does it happen in a online race too?
     
  11. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    Thanks for your reply.The other games don't have the same problem. I haven't looked at the Windows Event Viewer, and I don't understand how to use it. But I will check it out. I've been playing singleplayer mode.
     
  12. regged

    regged Registered

    Joined:
    May 25, 2012
    Messages:
    42
    Likes Received:
    16
    You may want to run some tests on the memory just to make sure it is good if nothing else:
    To launch the Windows Memory Diagnostic tool, open the Start menu, type “Windows Memory Diagnostic”, and press Enter.
     
    DJCruicky likes this.
  13. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    Hi, I checked the event viewer and nothing about RF2 appears. thank you for your help. I've been dealing with this for days and I've had enough, I've given up. fuck!
     
  14. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    Thank you for your reply. I tried launching the Windows Memory Diagnostic Tool as you said, and no errors came up. I'm about to give up, even though I love this game. thanks again
     
  15. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,023
    Likes Received:
    5,697
    What's the current status? Works but with the trace errors? Or back to crashing?
     
  16. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    thank you for your reply. It didn't get better. There will still be crashes. It is only probabilistic to be able to drive successfully. After changing the track or changing the car, loading again will still crash.:(:(
    I uploaded the latest tracking file.I hope it helps.
    thanks
     

    Attached Files:

  17. ddooewq

    ddooewq Registered

    Joined:
    Jun 17, 2022
    Messages:
    33
    Likes Received:
    2
    Is there no staff to take a look? ? My problem has been around for a long time.
     
  18. davehenrie

    davehenrie Registered

    Joined:
    Jul 6, 2016
    Messages:
    6,325
    Likes Received:
    3,644
    But your problem is unique, at least in some respect. I have almost the exact system as you and it operates as expected. rF2 does not crash when loading nor operating. So we have to assume 2 things.
    1. It is not something the devs can identify, duplicate and understand. Therefore is is not something they can address without much more data.
    2. As it does not appear to crash my system or other systems like ours, it has to be a problem, somehow, on your end. By process of elimination, we MAY find a solution to your problem. But you have already covered most of the known solutions so even that bit of hope is grim. Work with Lazza and the rest of us, we will try to help.
     
  19. Lazza

    Lazza Registered

    Joined:
    Oct 5, 2010
    Messages:
    11,023
    Likes Received:
    5,697
    @ddooewq there's nothing consistently showing in the traces (that last one just stops for no reason) which usually indicates something outside of rF2 is stopping it - can you check event viewer again for the time(s) it crashed? It won't necessarily mention rF2, especially if it's a display driver or similar. Note also there are a couple of sections in event viewer where relevant errors could appear.

    Have you tried without your wheel and pedals plugged in?

    Is your windows set to something other than English?

    Did you leave the windows virtual memory settings on default? (automatically managed)
     
  20. redapg

    redapg Registered

    Joined:
    Jan 16, 2012
    Messages:
    2,801
    Likes Received:
    1,579
    @ddooewq As said by @davehenrie, that really seems to be a Problem on your Machine and the Trace Files are not really give an useful Hint about a possible Reason.
    Just 2 Shots into the Dark:
    1. Do you run the Graphics Settings before you start the Game and select the correct Graphics Card there?
    2. Did you try running Steam/rFactor 2 as an Administrator?
     

Share This Page