5G with no port forwarding capability

Discussion in 'Hosting Help' started by buzz hornet, Jun 1, 2022.

  1. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    I recently moved home and processed a change of address with my internet provider. Unfortunately the internet speed at my new address was very poor, so I researched and decided on 5G. All was good, fantastic speed, no drop outs etc but when I went into the modem/router there is no capability to port forward, this was also confirmed by my new provider.

    I tried connecting another router (with port forwarding) which worked but I was getting conflicting DHCP, but as soon as I turned off DHCP on my 5G modem everything stopped working. I factory reset it and Re enabled DHCP and working again. Apparently there is a limitation with 5G that does not support port forwarding, I thought I worked it out with the additional router. I then looked at setting up a VPN and enable port forwarding but when I tried that the RF2 ports where already reserved and my provider was unable to assist.

    So I’m reaching out to somebody far smarter then me to suggest a way of getting RF2 to work with my router not supporting port forwarding. Any suggestions or reccomendations appreciated.

    thanks in advance
     
  2. atomed

    atomed Member

    Joined:
    Jul 9, 2019
    Messages:
    1,163
    Likes Received:
    1,132
    Have you tried using an already open port on your connection that you know you're not going to need?
     
    buzz hornet likes this.
  3. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    Thanks for the reply. Sorry I don’t follow. Do you mean with the 5 modem? All I did previously at my old house was to enable the RF2 ports (port forwarding) in my old routers and presto it worked.
    As I can’t port forward with my 5G modem I don’t know what to do. Sorry if I misunderstood your question.
     
  4. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    663
    Likes Received:
    198
    Helps if you post the make and model of the 5G modem, then others can atleast check its specs.
     
    buzz hornet and atomed like this.
  5. atomed

    atomed Member

    Joined:
    Jul 9, 2019
    Messages:
    1,163
    Likes Received:
    1,132
    I mean your 5g router may have some open ports for different purposes you don't need. Then you could assign those already open ports to be used in rF2
     
    buzz hornet likes this.
  6. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    Arcadyan AW1000
     
  7. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    Ok thanks I’ll take a look and see what I can find.
     
  8. trichens

    trichens Registered

    Joined:
    Nov 2, 2020
    Messages:
    96
    Likes Received:
    57
    Dumb question but you require port forwarding because you are running a rF2 server?
    A couple of things to look at / consider...
    Your second router that you set port forwarding on you say worked but there were DHCP issues... can you not turn off the DHCP server on the second router?
    The 5G router has a Firewall page you can access? What is configured there, if anything?
    Lastly, you can change the ports being used in the config files.. would this be possible?
     
  9. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    Yes use to setup a server for multiplayer racing.
    I turned off DHCP on non 5g router all good, I then turned it back on as I wanted it to be the master. But as soon as I turned off DHCP on the 5G modem I lost all internet. It’s like DHCP must always be enabled on the 5G modem.
    it does have a firewall page but very limited where you can not define TCP or UDP just permission via an IP address.
    Haven’t found any config files which display open ports.
     
  10. Mangoletsi

    Mangoletsi Registered

    Joined:
    Feb 2, 2012
    Messages:
    663
    Likes Received:
    198
    Hi, just googled your router, do you not have this port forwarding page on your version?
    https://imgur.io/a/HNbviTE

    at the bottom of the page, in the section labelled user defined service
     
  11. trichens

    trichens Registered

    Joined:
    Nov 2, 2020
    Messages:
    96
    Likes Received:
    57
    I would expect to see something like the image @Mangoletsi has linked to.

    Can you post an image of the firewall screen?

    Sorry, I realised I wasn't very clear; the port number change I was thinking of was the files used to config the ports used by the rF2 server.
     
    Last edited: Jun 1, 2022
  12. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    Thanks all for your assistance to date, I can confirm that I have that setting in the router (as per screenshot you provided)
    Knowing I need to configure the following:
    • TCP: 54297, 64297
    • UDP: 54297
    Can you advise what I need to put in the top section (Network > Firewall > Access Control > Add Rule)
    eg) do I need to enter my IP address in the client IP address or the destination IP address?

    And also the bottom section (User Define Service)
    eg) Source Port Range or Destination Port Rang?
     
  13. trichens

    trichens Registered

    Joined:
    Nov 2, 2020
    Messages:
    96
    Likes Received:
    57
    OK... problem.
    It seems that the port forwarding is under the NAT settings tab.
    If you select this you'll get a message that this option is disabled - it seems like you can't change this to add your own.
    So we'll have to assume that all ports are open.

    You said you tried using a second router but got a IP address conflict issue?
    Turning off the DHCP on the 5G router killed internet access.

    We can see if changing the IP config on both the 5G and second router will solve the problem.
    So...
    The 5G router has LAN IP address 192.168.0.1
    You shold be able to turn off DHCP on this if you configure your client device to use a fixed IP address and settings... you may want to turn off the wireless access on this too.

    On the second router set the WAN IP address to be 192.168.0.2
    BTW which router is this?
    You'll need to set the WAN gateway to be 192.168.0.1

    This should now be sending everything for the second LAN to the WAN interface and therefore out to the 5G router.
    Configure the second router LAN to use IP address arrange 192.168.1.xxx
    Set the LAN IP address for the router to be 192.168.1.1 and its DHCP to distribute 192.168.1.xxx IP addresses to the local PCs
    DNS will have to be set too - try the same as the 5G router or use the Google ones - 8.8.8.8 and 8.8.4.4

    What should be happening is that the 5G router gets packets in and sends them out on the LAN interface 192.168.0 subnet.
    The secound router WAN interface gets these as it's on the 192.168.0 subnet.
    As this is acting as a gateway then anything that comes in on the WAN interface then gets sent out on the LAN interface 192.168.1 subnet. This uses a different IP address range so there is no conflict.
    You can then use the port forwarding options on the second router.
    This should work as long as your second router is just that - it shouldn't have an internal modem built in.

    I hope that reads OK?
     
    Last edited: Jun 2, 2022
    buzz hornet likes this.
  14. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    Thank you for your comprehensive reply, I really appreciate it.
    To answer some of your questions.

    5G Modem = Arcadyan AW1000 (IP address 192.168.0.1)
    Second Router = TPLink AX5400 (Which is a Modem/Router with port forwarding capability - Default IP address 192.168.1.1)

    The second modem is a TPLink AX5400. I plugged it directly into my 5G Modem (Arcadyan AW1000) via Ethernet. I then plugged my 2 x PC's (not wireless) via Enternet into the TPLink AX5400. And yes when I did that, I had conflicting DHCP - internet dropped in and out. I then turned off DHCP on the TPLink AX5400 just to test the internet - all good as the DHCP was now being exclusively controlled by the Arcadyan AW1000. I then turned DHCP back on the TPLink AX5400 and disabled the DHCP on the Arcadyan AW1000 - no internet at all - network dead. Did a factory reset to restore DHCP and internet/network came back alive. Currently I am just just connected only to the modem - Arcadyan AW1000 thus trying to see if there was a way to get it to Port Forward. Seems that is not possible. So can play all other games, but not RF2 multiplayer with me as a the host.

    Just going through your post my PC's (Win10) each have IP settings set to Automatic (DHCP). What IP address should I use for the client PC's?

    I think I can follow most of what you said, I am not super techy - but know enough to generally get around the Network. I may require some assistence regarding where to put the parameter settings on the TPLink AX5400. But yes it seems I have to do the Port forwarding on the TPLink AX5400 as the 5G Arcadyan AW1000 just does not support it. Hoping that the TPLink AX5400 will do the job - but it is both a Modem and Router.
     
    Last edited: Jun 2, 2022
  15. trichens

    trichens Registered

    Joined:
    Nov 2, 2020
    Messages:
    96
    Likes Received:
    57
    I "think" the following settings on the TP-Link "should" work but obviously I can't test :)

    So this will make your TL-Link and 5G talk to each other - output from 5G into TP-Link WAN port
    router01.jpg

    And this will set the LAN IP address for your home network
    router02.jpg
    And this will pass out IP addresses to your home network
    router03.jpg
     
    buzz hornet likes this.
  16. trichens

    trichens Registered

    Joined:
    Nov 2, 2020
    Messages:
    96
    Likes Received:
    57
    I suspect the issue with the 5G DHCP is that it's firing out IP addresses and your local PCs being set to Automatic will pick up anything.
    With the 5G DHCP off the TP-Link probably didn't get a WAN IP address as the 5G router wasn't giving one out.
    By setting the IP address config manually you should avoid that issue... fingers crossed!
     
    buzz hornet likes this.
  17. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    Thank you so much my friend, I will make a start on this before the weekend. I really appreciate the time and effort you have taken to help me.
     
  18. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    @trichens

    No luck, tried everything and nothing worked. I have since cancelled the 5G service and going to revert to a standard NBN plan - it might be slow but at least it works. I do appreciate everything you did to assist me.

     
  19. trichens

    trichens Registered

    Joined:
    Nov 2, 2020
    Messages:
    96
    Likes Received:
    57
    Rats! That's really annoying @buzz hornet
    Sorry it didn't work for you.
     
  20. buzz hornet

    buzz hornet Registered

    Joined:
    Oct 5, 2010
    Messages:
    274
    Likes Received:
    157
    Yes tried everything, so unfortunate. I got my normal internet back on yesterday, enabled port forwarding in RF2 and presto worked instantly.
    The problem with the 5g it wanted to always control the DHCP. Other issues was it was restricted to 1TB per month, my daughter streams in 4K so that can consume as much as 7Gb per hour. And the other issue is that the technology does not always connect to wifi devices such as smart tvs and Apple TV etc. As soon as I got internet back, everything came back alive.

    Hopefully this thread will help others who switch to 5G.
     
    Last edited: Jun 8, 2022

Share This Page