3DS Max 2012 x64 GMT exporter billboards BUG

Discussion in 'Bug Reports' started by Elwood Blues, Sep 24, 2018.

  1. Elwood Blues

    Elwood Blues Registered

    Joined:
    Aug 15, 2018
    Messages:
    9
    Likes Received:
    0
    I've just wasted a whole day trying to set up stamp vertex alpha billboard branches for 3D trees.
    And yes, I have followed the documentation, the tutorials, the forums, the cheat sheet:
    • vertex bottom line 1 > 2
    • triangulation from top left to bottom right
    • vertex alpha set to 99.99
    • gmt exporter > screen aligned tools > ticked or "STMP" and center alignment
    • Bump Spec Map T1 Stamp Vertex
    • Vertex Color to be set to *a* value – even (255,255,255)
    • reset xform
    The objects do work - to an extent. The extent is that there can be no more than 16 alpha screen-aligned-quads in a single gmt object. If this number is exceeded, this happens: trees_BUG_2.jpg
    trees_BUG.jpg
    This is just a simple object with 48 multiplied polys.
    About 30% of the planes are not rotating, and several are rotated or skewed in strange ways.
    Of course all the planes have same shader, triangulation and vertex numbering and values. They are copies.
    The moment the poly count is reduced to 16 polys (32 triangles) by deleting RANDOM elements, they all magically start working properly. Yes, you can literally delete all the polys that do work good, and the rest (for example the middle section in the lower pic) will begin to work right without any further changes ;(
    In the April update https://www.studio-397.com/2018/04/release-of-build-1110/ it is stated that the x64 plugins are used by the 397 team... so how about changing the BETA status of the x64 plugins to "production"?
     
  2. Nibiru

    Nibiru Registered

    Joined:
    Dec 24, 2011
    Messages:
    1,198
    Likes Received:
    1,270
    I cant comment on 64 bit but 32 bit works fine for me. I can have 100s of billboards together. Just make sure each billboards pivot is centered to itself then join as 1 object. Seems like some of your billboards have bad pivots.
     
  3. Elwood Blues

    Elwood Blues Registered

    Joined:
    Aug 15, 2018
    Messages:
    9
    Likes Received:
    0
    Thank you for the suggestion, but detaching the sub-elements, centering pivots and re-attaching did not fix the issue.
    The problem simply begins for me when there is 17 or more screen-aligned-quads in one object. That is all.
    I will install max 2010 32 bit now and check if the problem persists.
     
  4. Coutie

    Coutie Moderator

    Joined:
    Oct 5, 2010
    Messages:
    2,500
    Likes Received:
    1,307
    There does seem to be an issue with the 64bit plug-ins, BB objects don't work, and if you have and reflections set up it'll crash when you open the exporter, or if you open a material with reflections set up in the material editor.
     
  5. Elwood Blues

    Elwood Blues Registered

    Joined:
    Aug 15, 2018
    Messages:
    9
    Likes Received:
    0
    Confirmed - just tried exporting same object in max 2012 x86 (32 bit) and it is working fine in the game.
    Avoid using the x64 plugin until this is fixed.
     
  6. Bernd

    Bernd Registered

    Joined:
    Jul 9, 2013
    Messages:
    1,451
    Likes Received:
    678
    I did make some billboard crowd meshes in 3dsmax 64 bit.
    After exporting, the meshes have been corrupted.
    I tried a lot of things to get it fixed, but nothing worked.
    I then tried it with the 32 bit version of 3dsmax and the 32 bit plugin, of course.
    With that, the exported meshes looked and worked properly.
    I have used the exact same scene file to export the meshes, in both cases.
    So i suspect that the 64 bit plugin has a bug.
    Here are some pictures.

    In 3dsmax
    inmax.jpg

    exported with 3dsmax 64 bit
    64bit.jpg

    exported with 3dsmax 32 bit
    32bit.jpg
     

Share This Page